Skip to content

Most visited

Recently visited

navigation

Script.FieldBase

public static class Script.FieldBase
extends Object

java.lang.Object
   ↳ android.renderscript.Script.FieldBase


Only intended for use by generated reflected code.

Summary

Fields

protected Allocation mAllocation

protected Element mElement

Protected constructors

Script.FieldBase()

Public methods

Allocation getAllocation()
Element getElement()
Type getType()
void updateAllocation()

Protected methods

void init(RenderScript rs, int dimx, int usages)
void init(RenderScript rs, int dimx)

Inherited methods

From class java.lang.Object

Fields

mAllocation

added in API level 11
Allocation mAllocation

mElement

added in API level 11
Element mElement

Protected constructors

Script.FieldBase

added in API level 11
Script.FieldBase ()

Public methods

getAllocation

added in API level 11
Allocation getAllocation ()

Returns
Allocation

getElement

added in API level 11
Element getElement ()

Returns
Element

getType

added in API level 11
Type getType ()

Returns
Type

updateAllocation

added in API level 11
void updateAllocation ()

Protected methods

init

added in API level 11
void init (RenderScript rs, 
                int dimx, 
                int usages)

Parameters
rs RenderScript

dimx int

usages int

init

added in API level 11
void init (RenderScript rs, 
                int dimx)

Parameters
rs RenderScript

dimx int

This site uses cookies to store your preferences for site-specific language and display options.

Get the latest Android developer news and tips that will help you find success on Google Play.

* Required Fields

Hooray!

Follow Google Developers on WeChat

Browse this site in ?

You requested a page in , but your language preference for this site is .

Would you like to change your language preference and browse this site in ? If you want to change your language preference later, use the language menu at the bottom of each page.

This class requires API level or higher

This doc is hidden because your selected API level for the documentation is . You can change the documentation API level with the selector above the left navigation.

For more information about specifying the API level your app requires, read Supporting Different Platform Versions.

Take a short survey?
Help us improve the Android developer experience.
(Sep 2017 survey)