Skip to content

Most visited

Recently visited

navigation
Added in API level 1

ProtectionDomain

public class ProtectionDomain
extends Object

java.lang.Object
   ↳ java.security.ProtectionDomain


Legacy security code; do not use.

Summary

Public constructors

ProtectionDomain(CodeSource cs, PermissionCollection permissions)
ProtectionDomain(CodeSource cs, PermissionCollection permissions, ClassLoader cl, Principal[] principals)

Public methods

final ClassLoader getClassLoader()
final CodeSource getCodeSource()
final PermissionCollection getPermissions()
final Principal[] getPrincipals()
boolean implies(Permission permission)

Inherited methods

From class java.lang.Object

Public constructors

ProtectionDomain

Added in API level 1
ProtectionDomain (CodeSource cs, 
                PermissionCollection permissions)

Parameters
cs CodeSource
permissions PermissionCollection

ProtectionDomain

Added in API level 1
ProtectionDomain (CodeSource cs, 
                PermissionCollection permissions, 
                ClassLoader cl, 
                Principal[] principals)

Parameters
cs CodeSource
permissions PermissionCollection
cl ClassLoader
principals Principal

Public methods

getClassLoader

Added in API level 1
ClassLoader getClassLoader ()

Returns
ClassLoader

getCodeSource

Added in API level 1
CodeSource getCodeSource ()

Returns
CodeSource

getPermissions

Added in API level 1
PermissionCollection getPermissions ()

Returns
PermissionCollection

getPrincipals

Added in API level 1
Principal[] getPrincipals ()

Returns
Principal[]

implies

Added in API level 1
boolean implies (Permission permission)

Parameters
permission Permission
Returns
boolean
This site uses cookies to store your preferences for site-specific language and display options.

Hooray!

This class requires API level or higher

This doc is hidden because your selected API level for the documentation is . You can change the documentation API level with the selector above the left navigation.

For more information about specifying the API level your app requires, read Supporting Different Platform Versions.