Skip to content

Most visited

Recently visited

navigation
Added in API level 1

UnsupportedClassVersionError

public class UnsupportedClassVersionError
extends ClassFormatError

java.lang.Object
   ↳ java.lang.Throwable
     ↳ java.lang.Error
       ↳ java.lang.LinkageError
         ↳ java.lang.ClassFormatError
           ↳ java.lang.UnsupportedClassVersionError


Thrown when an attempt is made to load a class with a format version that is not supported by the VM.

Summary

Public constructors

UnsupportedClassVersionError()

Constructs a new UnsupportedClassVersionError that includes the current stack trace.

UnsupportedClassVersionError(String detailMessage)

Constructs a new UnsupportedClassVersionError with the current stack trace and the specified detail message.

Inherited methods

From class java.lang.Throwable
From class java.lang.Object

Public constructors

UnsupportedClassVersionError

Added in API level 1
UnsupportedClassVersionError ()

Constructs a new UnsupportedClassVersionError that includes the current stack trace.

UnsupportedClassVersionError

Added in API level 1
UnsupportedClassVersionError (String detailMessage)

Constructs a new UnsupportedClassVersionError with the current stack trace and the specified detail message.

Parameters
detailMessage String: the detail message for this exception.
This site uses cookies to store your preferences for site-specific language and display options.

Hooray!

This class requires API level or higher

This doc is hidden because your selected API level for the documentation is . You can change the documentation API level with the selector above the left navigation.

For more information about specifying the API level your app requires, read Supporting Different Platform Versions.