Skip to content

Most visited

Recently visited

navigation
Added in API level 1

ArrayIndexOutOfBoundsException

public class ArrayIndexOutOfBoundsException
extends IndexOutOfBoundsException

java.lang.Object
   ↳ java.lang.Throwable
     ↳ java.lang.Exception
       ↳ java.lang.RuntimeException
         ↳ java.lang.IndexOutOfBoundsException
           ↳ java.lang.ArrayIndexOutOfBoundsException


Thrown when the an array is indexed with a value less than zero, or greater than or equal to the size of the array.

Summary

Public constructors

ArrayIndexOutOfBoundsException()

Constructs a new ArrayIndexOutOfBoundsException that includes the current stack trace.

ArrayIndexOutOfBoundsException(int index)

Constructs a new ArrayIndexOutOfBoundsException with the current stack trace and a detail message that is based on the specified invalid index.

ArrayIndexOutOfBoundsException(String detailMessage)

Constructs a new ArrayIndexOutOfBoundsException with the current stack trace and the specified detail message.

Inherited methods

From class java.lang.Throwable
From class java.lang.Object

Public constructors

ArrayIndexOutOfBoundsException

Added in API level 1
ArrayIndexOutOfBoundsException ()

Constructs a new ArrayIndexOutOfBoundsException that includes the current stack trace.

ArrayIndexOutOfBoundsException

Added in API level 1
ArrayIndexOutOfBoundsException (int index)

Constructs a new ArrayIndexOutOfBoundsException with the current stack trace and a detail message that is based on the specified invalid index.

Parameters
index int: the invalid index.

ArrayIndexOutOfBoundsException

Added in API level 1
ArrayIndexOutOfBoundsException (String detailMessage)

Constructs a new ArrayIndexOutOfBoundsException with the current stack trace and the specified detail message.

Parameters
detailMessage String: the detail message for this exception.
This site uses cookies to store your preferences for site-specific language and display options.

Hooray!

This class requires API level or higher

This doc is hidden because your selected API level for the documentation is . You can change the documentation API level with the selector above the left navigation.

For more information about specifying the API level your app requires, read Supporting Different Platform Versions.