Skip to content

Most visited

Recently visited

navigation

EGLExt

public class EGLExt
extends Object

java.lang.Object
   ↳ android.opengl.EGLExt


EGL Extensions

Summary

Constants

int EGL_CONTEXT_FLAGS_KHR

int EGL_CONTEXT_MAJOR_VERSION_KHR

int EGL_CONTEXT_MINOR_VERSION_KHR

int EGL_OPENGL_ES3_BIT_KHR

int EGL_RECORDABLE_ANDROID

Public constructors

EGLExt()

Public methods

static boolean eglPresentationTimeANDROID(EGLDisplay dpy, EGLSurface sur, long time)

Inherited methods

From class java.lang.Object

Constants

EGL_CONTEXT_FLAGS_KHR

added in API level 18
int EGL_CONTEXT_FLAGS_KHR

Constant Value: 12540 (0x000030fc)

EGL_CONTEXT_MAJOR_VERSION_KHR

added in API level 18
int EGL_CONTEXT_MAJOR_VERSION_KHR

Constant Value: 12440 (0x00003098)

EGL_CONTEXT_MINOR_VERSION_KHR

added in API level 18
int EGL_CONTEXT_MINOR_VERSION_KHR

Constant Value: 12539 (0x000030fb)

EGL_OPENGL_ES3_BIT_KHR

added in API level 18
int EGL_OPENGL_ES3_BIT_KHR

Constant Value: 64 (0x00000040)

EGL_RECORDABLE_ANDROID

added in API level 26
int EGL_RECORDABLE_ANDROID

Constant Value: 12610 (0x00003142)

Public constructors

EGLExt

added in API level 18
EGLExt ()

Public methods

eglPresentationTimeANDROID

added in API level 18
boolean eglPresentationTimeANDROID (EGLDisplay dpy, 
                EGLSurface sur, 
                long time)

Parameters
dpy EGLDisplay

sur EGLSurface

time long

Returns
boolean

This site uses cookies to store your preferences for site-specific language and display options.

Get the latest Android developer news and tips that will help you find success on Google Play.

* Required Fields

Hooray!

Browse this site in ?

You requested a page in , but your language preference for this site is .

Would you like to change your language preference and browse this site in ? If you want to change your language preference later, use the language menu at the bottom of each page.

This class requires API level or higher

This doc is hidden because your selected API level for the documentation is . You can change the documentation API level with the selector above the left navigation.

For more information about specifying the API level your app requires, read Supporting Different Platform Versions.

Take a short survey?
Help us improve the Android developer experience.
(Sep 2017 survey)