Skip to content

Most visited

Recently visited

navigation
added in API level 1

AutoCompleteTextView.Validator

public static interface AutoCompleteTextView.Validator

android.widget.AutoCompleteTextView.Validator


This interface is used to make sure that the text entered in this TextView complies to a certain format. Since there is no foolproof way to prevent the user from leaving this View with an incorrect value in it, all we can do is try to fix it ourselves when this happens.

Summary

Public methods

abstract CharSequence fixText(CharSequence invalidText)

Corrects the specified text to make it valid.

abstract boolean isValid(CharSequence text)

Validates the specified text.

Public methods

fixText

added in API level 1
CharSequence fixText (CharSequence invalidText)

Corrects the specified text to make it valid.

Parameters
invalidText CharSequence: A string that doesn't pass validation: isValid(invalidText) returns false

Returns
CharSequence A string based on invalidText such as invoking isValid() on it returns true.

See also:

isValid

added in API level 1
boolean isValid (CharSequence text)

Validates the specified text.

Parameters
text CharSequence

Returns
boolean true If the text currently in the text editor is valid.

See also:

This site uses cookies to store your preferences for site-specific language and display options.

Get the latest Android developer news and tips that will help you find success on Google Play.

* Required Fields

Hooray!

Follow Google Developers on WeChat

Browse this site in ?

You requested a page in , but your language preference for this site is .

Would you like to change your language preference and browse this site in ? If you want to change your language preference later, use the language menu at the bottom of each page.

This class requires API level or higher

This doc is hidden because your selected API level for the documentation is . You can change the documentation API level with the selector above the left navigation.

For more information about specifying the API level your app requires, read Supporting Different Platform Versions.

Take a short survey?
Help us improve the Android developer experience.
(Sep 2017 survey)