Skip to content

Most visited

Recently visited

navigation
Added in API level 1

IllegalFormatCodePointException

public class IllegalFormatCodePointException
extends IllegalFormatException implements Serializable

java.lang.Object
   ↳ java.lang.Throwable
     ↳ java.lang.Exception
       ↳ java.lang.RuntimeException
         ↳ java.lang.IllegalArgumentException
           ↳ java.util.IllegalFormatException
             ↳ java.util.IllegalFormatCodePointException


An IllegalFormatCodePointException will be thrown if an invalid Unicode code point (defined by isValidCodePoint(int)) is passed as a parameter to a Formatter.

See also:

Summary

Public constructors

IllegalFormatCodePointException(int c)

Constructs a new IllegalFormatCodePointException which is specified by the invalid Unicode code point.

Public methods

int getCodePoint()

Returns the invalid Unicode code point.

String getMessage()

Returns the detail message which was provided when this Throwable was created.

Inherited methods

From class java.lang.Throwable
From class java.lang.Object

Public constructors

IllegalFormatCodePointException

Added in API level 1
IllegalFormatCodePointException (int c)

Constructs a new IllegalFormatCodePointException which is specified by the invalid Unicode code point.

Parameters
c int: the invalid Unicode code point.

Public methods

getCodePoint

Added in API level 1
int getCodePoint ()

Returns the invalid Unicode code point.

Returns
int the invalid Unicode code point.

getMessage

Added in API level 1
String getMessage ()

Returns the detail message which was provided when this Throwable was created. Returns null if no message was provided at creation time.

Returns
String
This site uses cookies to store your preferences for site-specific language and display options.

Hooray!

This class requires API level or higher

This doc is hidden because your selected API level for the documentation is . You can change the documentation API level with the selector above the left navigation.

For more information about specifying the API level your app requires, read Supporting Different Platform Versions.