Passer directement au contenu

Les plus consultés

Consultés récemment

navigation
added in API level 18

RemoteControlClient.OnPlaybackPositionUpdateListener

public static interface RemoteControlClient.OnPlaybackPositionUpdateListener

android.media.RemoteControlClient.OnPlaybackPositionUpdateListener


Interface definition for a callback to be invoked when the media playback position is requested to be updated.

See also:

Summary

Public methods

abstract void onPlaybackPositionUpdate(long newPositionMs)

Called on the implementer to notify it that the playback head should be set at the given position.

Public methods

onPlaybackPositionUpdate

added in API level 18
void onPlaybackPositionUpdate (long newPositionMs)

Called on the implementer to notify it that the playback head should be set at the given position. If the position can be changed from its current value, the implementor of the interface must also update the playback position using setPlaybackState(int, long, float) to reflect the actual new position being used, regardless of whether it differs from the requested position. Failure to do so would cause the system to not know the new actual playback position, and user interface components would fail to show the user where playback resumed after the position was updated.

Parameters
newPositionMs long: the new requested position in the current media, expressed in ms.

Ce site Web utilise des cookies pour enregistrer vos préférences relatives à la langue du site et aux options d'affichage.

Recevez les dernières actualités destinées aux développeurs Android, ainsi que des conseils qui vous mèneront vers le succès sur Google Play.

* Champs obligatoires

Super !

Suivez Google Developers sur WeChat

Consulter ce site en  ?

Vous avez demandé une page en , mais la langue indiquée dans vos préférences linguistiques pour ce site est la suivante : .

Souhaitez-vous modifier vos préférences linguistiques et parcourir ce site en  ? Pour modifier ultérieurement vos préférences linguistiques, utilisez le menu "Langue" au bas de chaque page.

Cette classe nécessite le niveau d'API  ou supérieur

Ce document est masqué, car vous avez sélectionné le niveau d'API  pour la documentation. Vous pouvez modifier le niveau d'API pour la documentation avec le sélecteur situé au-dessus du menu de navigation de gauche.

Pour découvrir comment déterminer le niveau d'API nécessaire pour votre application, consultez le guide sur la prise en charge des différentes versions de plate-forme (en anglais).

Take a short survey?
Help us improve the Android developer experience. (April 2018 — Developer Survey)