Skip to content

Most visited

Recently visited

navigation
Added in API level 1
Deprecated since API level 13

KeyguardManager.KeyguardLock

public class KeyguardManager.KeyguardLock
extends Object

java.lang.Object
   ↳ android.app.KeyguardManager.KeyguardLock


This class was deprecated in API level 13.
Use FLAG_DISMISS_KEYGUARD and/or FLAG_SHOW_WHEN_LOCKED instead; this allows you to seamlessly hide the keyguard as your application moves in and out of the foreground and does not require that any special permissions be requested. Handle returned by newKeyguardLock(String) that allows you to disable / reenable the keyguard.

Summary

Public methods

void disableKeyguard()

Disable the keyguard from showing.

void reenableKeyguard()

Reenable the keyguard.

Inherited methods

From class java.lang.Object

Public methods

disableKeyguard

Added in API level 1
void disableKeyguard ()

Disable the keyguard from showing. If the keyguard is currently showing, hide it. The keyguard will be prevented from showing again until reenableKeyguard() is called. A good place to call this is from onResume() Note: This call has no effect while any DevicePolicyManager is enabled that requires a password.

This method requires the caller to hold the permission DISABLE_KEYGUARD.

See also:

reenableKeyguard

Added in API level 1
void reenableKeyguard ()

Reenable the keyguard. The keyguard will reappear if the previous call to disableKeyguard() caused it to be hidden. A good place to call this is from onPause() Note: This call has no effect while any DevicePolicyManager is enabled that requires a password.

This method requires the caller to hold the permission DISABLE_KEYGUARD.

See also:

This site uses cookies to store your preferences for site-specific language and display options.

Hooray!

This class requires API level or higher

This doc is hidden because your selected API level for the documentation is . You can change the documentation API level with the selector above the left navigation.

For more information about specifying the API level your app requires, read Supporting Different Platform Versions.