Skip to content

Most visited

Recently visited

navigation

ServiceConfigurationError

public class ServiceConfigurationError
extends Error

java.lang.Object
   ↳ java.lang.Throwable
     ↳ java.lang.Error
       ↳ java.util.ServiceConfigurationError


Error thrown when something goes wrong while loading a service provider.

This error will be thrown in the following situations:

  • The format of a provider-configuration file violates the specification;
  • An IOException occurs while reading a provider-configuration file;
  • A concrete provider class named in a provider-configuration file cannot be found;
  • A concrete provider class is not a subclass of the service class;
  • A concrete provider class cannot be instantiated; or
  • Some other kind of error occurs.

Summary

Public constructors

ServiceConfigurationError(String msg)

Constructs a new instance with the specified message.

ServiceConfigurationError(String msg, Throwable cause)

Constructs a new instance with the specified message and cause.

Inherited methods

From class java.lang.Throwable
From class java.lang.Object

Public constructors

ServiceConfigurationError

added in API level 9
ServiceConfigurationError (String msg)

Constructs a new instance with the specified message.

Parameters
msg String: The message, or null if there is no message

ServiceConfigurationError

added in API level 9
ServiceConfigurationError (String msg, 
                Throwable cause)

Constructs a new instance with the specified message and cause.

Parameters
msg String: The message, or null if there is no message

cause Throwable: The cause, or null if the cause is nonexistent or unknown

This site uses cookies to store your preferences for site-specific language and display options.

Get the latest Android developer news and tips that will help you find success on Google Play.

* Required Fields

Hooray!

Follow Google Developers on WeChat

Browse this site in ?

You requested a page in , but your language preference for this site is .

Would you like to change your language preference and browse this site in ? If you want to change your language preference later, use the language menu at the bottom of each page.

This class requires API level or higher

This doc is hidden because your selected API level for the documentation is . You can change the documentation API level with the selector above the left navigation.

For more information about specifying the API level your app requires, read Supporting Different Platform Versions.

Take a short survey?
Help us improve the Android developer experience.
(Sep 2017 survey)