Skip to content

Most visited

Recently visited

navigation
Added in API level 1

AnnotationFormatError

public class AnnotationFormatError
extends Error

java.lang.Object
   ↳ java.lang.Throwable
     ↳ java.lang.Error
       ↳ java.lang.annotation.AnnotationFormatError


Indicates that an annotation in the binary representation of a class is syntactically incorrect and the annotation parser is unable to process it. This exception is unlikely to ever occur, given that the code has been compiled by an ordinary Java compiler.

Summary

Public constructors

AnnotationFormatError(String message)

Constructs an instance with the message provided.

AnnotationFormatError(String message, Throwable cause)

Constructs an instance with a message and a cause.

AnnotationFormatError(Throwable cause)

Constructs an instance with a cause.

Inherited methods

From class java.lang.Throwable
From class java.lang.Object

Public constructors

AnnotationFormatError

Added in API level 1
AnnotationFormatError (String message)

Constructs an instance with the message provided.

Parameters
message String: the details of the error.

AnnotationFormatError

Added in API level 1
AnnotationFormatError (String message, 
                Throwable cause)

Constructs an instance with a message and a cause.

Parameters
message String: the details of the error.
cause Throwable: the cause of the error or null if none.

AnnotationFormatError

Added in API level 1
AnnotationFormatError (Throwable cause)

Constructs an instance with a cause. If the cause is not null, then cause.toString() is used as the error's message.

Parameters
cause Throwable: the cause of the error or null if none.
This site uses cookies to store your preferences for site-specific language and display options.

Hooray!

This class requires API level or higher

This doc is hidden because your selected API level for the documentation is . You can change the documentation API level with the selector above the left navigation.

For more information about specifying the API level your app requires, read Supporting Different Platform Versions.