Skip to content

Most visited

Recently visited

navigation
Added in API level 19

PdfDocument.PageInfo.Builder

public static final class PdfDocument.PageInfo.Builder
extends Object

java.lang.Object
   ↳ android.graphics.pdf.PdfDocument.PageInfo.Builder


Builder for creating a PdfDocument.PageInfo.

Summary

Public constructors

PdfDocument.PageInfo.Builder(int pageWidth, int pageHeight, int pageNumber)

Creates a new builder with the mandatory page info attributes.

Public methods

PdfDocument.PageInfo create()

Creates a new PdfDocument.PageInfo.

PdfDocument.PageInfo.Builder setContentRect(Rect contentRect)

Sets the content rectangle in PostScript point (1/72th of an inch).

Inherited methods

From class java.lang.Object

Public constructors

PdfDocument.PageInfo.Builder

Added in API level 19
PdfDocument.PageInfo.Builder (int pageWidth, 
                int pageHeight, 
                int pageNumber)

Creates a new builder with the mandatory page info attributes.

Parameters
pageWidth int: The page width in PostScript (1/72th of an inch).
pageHeight int: The page height in PostScript (1/72th of an inch).
pageNumber int: The page number.

Public methods

create

Added in API level 19
PdfDocument.PageInfo create ()

Creates a new PdfDocument.PageInfo.

Returns
PdfDocument.PageInfo The new instance.

setContentRect

Added in API level 19
PdfDocument.PageInfo.Builder setContentRect (Rect contentRect)

Sets the content rectangle in PostScript point (1/72th of an inch). This is the area that contains the page content and is relative to the page top left.

Parameters
contentRect Rect: The content rectangle. Must fit in the page.
Returns
PdfDocument.PageInfo.Builder
This site uses cookies to store your preferences for site-specific language and display options.

Hooray!

This class requires API level or higher

This doc is hidden because your selected API level for the documentation is . You can change the documentation API level with the selector above the left navigation.

For more information about specifying the API level your app requires, read Supporting Different Platform Versions.