Stay organized with collections Save and categorize content based on your preferences.

AarMetadata

interface AarMetadata
com.android.build.api.variant.AarMetadata

Variant object for configuring AAR metadata.

Summary

Properties

abstract Property<String>

Minimum Android Gradle Plugin version needed to consume this library.

abstract Property<Int>

Minimum compileSdkVersion needed to consume this library.

Properties

minAgpVersion

abstract val minAgpVersion: Property<String>

Minimum Android Gradle Plugin version needed to consume this library. This is the minimum AGP version a module must use in order to import this library.

minAgpVersion must be a stable AGP version, and it must be formatted with major, minor, and micro values (for example, "4.0.0").

minCompileSdk

abstract val minCompileSdk: Property<Int>

Minimum compileSdkVersion needed to consume this library. This is the minimum sdk version a module must use in order to import this library.