lightbulb_outline Please take our October 2018 developer survey. Start survey

RequiresApi

public abstract @interface RequiresApi
implements Annotation

android.support.annotation.RequiresApi


Denotes that the annotated element should only be called on the given API level or higher.

This is similar in purpose to the older @TargetApi annotation, but more clearly expresses that this is a requirement on the caller, rather than being used to "suppress" warnings within the method that exceed the minSdkVersion.

Summary

Public methods

int api()

The API level to require

int value()

The API level to require.

Inherited methods

From interface java.lang.annotation.Annotation

Public methods

api

int api ()

The API level to require

Returns
int

Value is 1 or greater.

value

int value ()

The API level to require. Alias for api() which allows you to leave out the api= part.

Returns
int

Value is 1 or greater.