Skip to content

Most visited

Recently visited

navigation

LeanbackListPreferenceDialogFragment.ViewHolder

public static class LeanbackListPreferenceDialogFragment.ViewHolder
extends RecyclerView.ViewHolder implements View.OnClickListener

java.lang.Object
   ↳ android.support.v7.widget.RecyclerView.ViewHolder
     ↳ android.support.v17.preference.LeanbackListPreferenceDialogFragment.ViewHolder


Summary

Nested classes

interface LeanbackListPreferenceDialogFragment.ViewHolder.OnItemClickListener

 

Inherited fields

From class android.support.v7.widget.RecyclerView.ViewHolder

Public constructors

LeanbackListPreferenceDialogFragment.ViewHolder(View view, LeanbackListPreferenceDialogFragment.ViewHolder.OnItemClickListener listener)

Public methods

ViewGroup getContainer()
TextView getTitleView()
Checkable getWidgetView()
void onClick(View v)

Called when a view has been clicked.

Inherited methods

From class android.support.v7.widget.RecyclerView.ViewHolder
From class java.lang.Object
From interface android.view.View.OnClickListener

Public constructors

LeanbackListPreferenceDialogFragment.ViewHolder

added in version 23.0.0
LeanbackListPreferenceDialogFragment.ViewHolder (View view, 
                LeanbackListPreferenceDialogFragment.ViewHolder.OnItemClickListener listener)

Parameters
view View
listener LeanbackListPreferenceDialogFragment.ViewHolder.OnItemClickListener

Public methods

getContainer

added in version 23.0.0
ViewGroup getContainer ()

Returns
ViewGroup

getTitleView

added in version 23.0.0
TextView getTitleView ()

Returns
TextView

getWidgetView

added in version 23.0.0
Checkable getWidgetView ()

Returns
Checkable

onClick

added in version 23.0.0
void onClick (View v)

Called when a view has been clicked.

Parameters
v View: The view that was clicked.
This site uses cookies to store your preferences for site-specific language and display options.

Hooray!

This class requires API level or higher

This doc is hidden because your selected API level for the documentation is . You can change the documentation API level with the selector above the left navigation.

For more information about specifying the API level your app requires, read Supporting Different Platform Versions.

Take a one-minute survey?
Help us improve Android tools and documentation.