Skip to content

Most visited

Recently visited

navigation

Resolver problemas do Android Studio

Esta página contém orientação para solucionar problemas comuns e de configuração no Android Studio.

Telas de alta densidade

A partir da versão 1.5, o Android Studio é compatível com telas de alta densidade (como monitores HiDPI e Retina) em todas as plataformas.

Configurações de fator de escala

O Android Studio determina o fator de escala da sua tela da seguinte forma:

Mac
Em telas Retina, a escala dos elementos de IU é ajustada por um fator de 200% e as imagens são renderizadas em alta resolução. O ajuste de escala não deve provocar imagens desfocadas, mesmo em configurações de várias telas. Observe que não são permitidos fatores de escala diferentes de 100% (para monitores que não são Retina) e 200% (para monitores Retina).
Windows
O Android Studio usa as configurações de DPI da tela principal para determinar o fator de escala dos elementos de IU. Para imagens, se o fator de escala for inferior a 150%, a escala das imagens com resolução normal será aumentada. Se o fator de escala for maior que 150%, a escala das imagens de alta resolução será alterada adequadamente.
Linux
O Android Studio determina o fator de escala examinando o "Text Scaling Factor" e a configuração de DPI de sistema do XWindow.

Uma configuração de DPI de 96 corresponde a um fator de escala de 100% (sem alteração de escala) e uma configuração de DPI de 192 corresponde a um fator de escala de 200% (o tamanho dos elementos de IU é dobrado). No momento, o Android Studio permite configurações de DPI entre 96 (escala de 100%) e 288 (escala de 300%).

Se o Android Studio não detectar o DPI de sistema correto em uma máquina Linux ou Windows, você poderá defini-lo manualmente configurando a propriedade hidpi no arquivo ide.properties, como descrito em Personalizar propriedades do IDE. Observe que essa propriedade não tem efeito em máquinas Mac. A propriedade funciona da seguinte forma:

hidpi=true
Define o DPI para 192 (escala de 200%), ignorando as configurações do sistema.
hidpi=false
Define o DPI para 96 (escala de 100%), ignorando as configurações do sistema.

Elementos desfocados ou serrilhados em telas de alta densidade

Se um ou mais elementos da IU do Android Studio aparecer desfocado ou serrilhado em uma tela de alta densidade, um dos problemas as seguir poderá ser o responsável:

Elementos com tamanho incorreto e telas de alta densidade

Se toda a IU do Android Studio estiver com o tamanho errado na tela de alta densidade, consulte Configurações de fator de escala. Se alguns elementos da IU do Android Studio estiverem com o tamanho errado na tela de alta densidade, mas outros elementos estiverem com o tamanho correto, um dos problemas a seguir poderá ser o responsável:

Bibliotecas do Linux

Se você estiver executando o Android Studio em uma máquina Linux 64 bits, poderá ser necessário instalar algumas bibliotecas específicas, como descrito a seguir.

Se você estiver executando uma versão do Ubuntu de 64 bits, será necessário instalar algumas bibliotecas de 32 bits com o comando a seguir:

sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386 lib32z1 lib32bz2-1.0

Se você estiver executando o Fedora de 64 bits, o comando será:

sudo yum install zlib.i686 ncurses-libs.i686 bzip2-libs.i686

Problemas de sincronismo do projeto

Ao tentar sincronizar um projeto, você poderá receber a seguinte mensagem de erro: "Connection to the Internet denied. ('Permission denied: connect')". Essa mensagem de erro pode ser resolvida adicionando a propriedade de sistema -Djava.net.preferIPv4Stack=true ao arquivo gradle.properties no Android Studio da seguinte forma:

  1. Abra o arquivo gradle.properties no Android Studio.
  2. Adicione a linha a seguir ao arquivo:
    org.gradle.jvmargs=-Djava.net.preferIPv4Stack=true
    
    Observe que, se já adicionou outros argumentos de JVM do Gradle ao arquivo gradle.properties, você poderá adicionar essa propriedade à mesma linha, como mostrado neste exemplo:
    org.gradle.jvmargs=-Xmx2048m -XX:MaxPermSize=512m -Djava.net.preferIPv4Stack=true
    
  3. Reinicie o Android Studio para que as alterações sejam aplicadas.
  4. Clique em Sync Project with Gradle Files para sincronizar o projeto.

Problemas atualizando o IDE no Windows

No Windows, os arquivos em uso por um processo não podem ser excluídos. Quando você tentar usar o mecanismo de atualização incorporado ao IDE, algumas vezes a atualização não é instalada, exibindo normalmente uma mensagem de erro como "Can't delete C:\algum\caminho\de\arquivo".

Para contornar esse problema, abra o gerenciador de tarefas e tente encerrar os processos que podem estar usando o arquivo, como todos os daemons do Gradle.

Problemas de minSdkVersion

Se você estiver usando uma versão obsoleta das Android Support Libraries, poderá receber uma mensagem de erro como esta:

:app:processDebugManifest app/src/main/AndroidManifest.xml:0:0 Error:
uses-sdk:minSdkVersion 19 cannot be smaller than version L declared in library app/build/intermediates/exploded-aar/com.android.support/appcompat-v7/21.0.0-rc1/AndroidManifest.xml
Suggestion: use tools:overrideLibrary="android.support.v7.appcompat" to force usage

Para resolver o problema, use o gerenciador do SDK para atualizar as bibliotecas para as versões mais recentes (não Preview) das Android Support Libraries. Para obter mais informações sobre a configuração das Support Libraries, consulte Configuração da Support Library.

This site uses cookies to store your preferences for site-specific language and display options.

Get the latest Android developer news and tips that will help you find success on Google Play.

* Required Fields

Hooray!

Follow Google Developers on WeChat

Browse this site in ?

You requested a page in , but your language preference for this site is .

Would you like to change your language preference and browse this site in ? If you want to change your language preference later, use the language menu at the bottom of each page.

This class requires API level or higher

This doc is hidden because your selected API level for the documentation is . You can change the documentation API level with the selector above the left navigation.

For more information about specifying the API level your app requires, read Supporting Different Platform Versions.

Take a short survey?
Help us improve the Android developer experience.
(Sep 2017 survey)