Skip to content

Most visited

Recently visited

navigation

Material Design para desarrolladores

Dependencias y requisitos previos

  • Android 5.0 (API nivel 21)

Material Design es una guía integral para el diseño visual, de movimientos y de interacción en distintas plataformas y dispositivos. Para usar Material Design en tus aplicaciones de Android, sigue las pautas descritas en la especificación de Material Design y usa los nuevos componentes y funcionalidades disponibles en Android 5.0 (API nivel 21).

Esta clase muestra cómo crear aplicaciones de Material Design con los siguientes elementos:

Esta clase también te enseña cómo mantener la compatibilidad con versiones anteriores de Android 5.0 (API nivel 21) cuando usas las características de Material Design en tu aplicación.

Lecciones

Comencemos
Aprende a actualizar tu aplicación con las características de Material Design.
Usar el tema Material
Aprende a aplicar los estilos de Material Design a tu aplicación.
Crear listas y tarjetas
Aprende a crear listas y tarjetas con un aspecto consistente mediante el uso de widgets del sistema.
Definir vistas de recorte y sombras
Aprende a establecer la elevación para tus vistas para crear sombras personalizadas y cómo recortar vistas.
Trabajar con interfaces dibujables
Aprende cómo crear interfaces dibujables en vector y cómo agregar un matiz a los recursos dibujables.
Definir animaciones personalizadas
Aprende a crear animaciones personalizadas para vistas y transiciones de actividades con elementos compartidos.
Mantener la compatibilidad
Aprende a mantener la compatibilidad con versiones de plataforma anteriores a Android 5.0.
This site uses cookies to store your preferences for site-specific language and display options.

Get the latest Android developer news and tips that will help you find success on Google Play.

* Required Fields

Hooray!

Follow Google Developers on WeChat

Browse this site in ?

You requested a page in , but your language preference for this site is .

Would you like to change your language preference and browse this site in ? If you want to change your language preference later, use the language menu at the bottom of each page.

This class requires API level or higher

This doc is hidden because your selected API level for the documentation is . You can change the documentation API level with the selector above the left navigation.

For more information about specifying the API level your app requires, read Supporting Different Platform Versions.

Take a short survey?
Help us improve the Android developer experience.
(Sep 2017 survey)