Restez organisé à l'aide des collections Enregistrez et classez les contenus selon vos préférences.

Remarque : Google Play utilise les éléments <uses-library> déclarés dans le fichier manifeste de votre application pour la filtrer dans les appareils qui ne répondent pas aux exigences de sa bibliothèque. Pour en savoir plus sur le filtrage, consultez la rubrique Filtres Google Play.

syntaxe :
<uses-library
  android:name="string"
  android:required=["true" | "false"] />
collections la contenant :
<application>
description :

Spécifie une bibliothèque partagée avec laquelle l'application doit être associée. Cet élément indique au système d'inclure le code de la bibliothèque dans le chargeur de classe du package.

Tous les packages android (tels que android.app, android.content, android.view et android.widget) se trouvent dans la bibliothèque par défaut à laquelle toutes les applications sont automatiquement associées. Cependant, certains packages (tels que maps) se trouvent dans des bibliothèques distinctes qui ne sont pas automatiquement associées. Consultez la documentation des packages que vous utilisez pour déterminer quelle bibliothèque contient le code du package.

L'ordre des balises <uses-library> est important : il affecte l'ordre de recherche et de résolution des classes lors du chargement de l'application. Certaines bibliothèques peuvent avoir des classes en double. Dans ce cas, la bibliothèque qui apparaît en premier est prioritaire.

Cet élément affecte également l'installation de l'application sur un appareil donné et sa disponibilité sur Google Play :

Installation
Si cet élément est présent et que son attribut android:required est défini sur true, le framework PackageManager ne permettra pas à l'utilisateur d'installer l'application, sauf si la bibliothèque est présente sur l'appareil de l'utilisateur.

L'attribut android:required est décrit en détail dans la section suivante.

attributs :
android:name
Nom de la bibliothèque. Le nom est fourni par la documentation du package que vous utilisez. Exemple : "android.test.runner", package contenant des classes de test Android.
android:required
Valeur booléenne indiquant si l'application nécessite la bibliothèque spécifiée par android:name :
  • "true" : l'application ne fonctionne pas sans cette bibliothèque. Le système n'autorisera pas l'application sur un appareil qui ne dispose pas de cette bibliothèque.
  • "false" : l'application peut utiliser la bibliothèque si elle est présente, mais elle est conçue pour fonctionner sans, si cela s'avère nécessaire. Le système autorise l'installation de l'application, même si la bibliothèque n'est pas présente. Si vous utilisez "false", vous devez vérifier que la bibliothèque est disponible au moment de l'exécution.

    Pour rechercher une bibliothèque, vous pouvez utiliser la réflexion pour déterminer si une classe spécifique est disponible.

La valeur par défaut est "true".

Introduit dans : niveau d'API 7.

introduit dans :
Niveau d'API 1
voir aussi :