Google 致力于为黑人社区推动种族平等。查看具体举措

AndroidX 版本说明归档

1.0.0

2018 年 9 月 21 日

这是 AndroidX 1.0.0 的稳定版本,适合在生产环境中使用。

新功能

1.0.0-rc02

2018 年 8 月 27 日

此 AndroidX 候选版本被视为功能完备,而且其公共 API Surface 也稳定。除非出现任何严重问题,否则此版本将作为最终稳定版推出。此版本应可在生产环境中放心使用。如有任何问题,请向公开问题跟踪器报告。

修复的问题

  • Proguard 移除了视图模型应用构造函数(公开问题 112230489
  • 修复了 AnimatedStateListDrawableCompat 常量状态
  • 从 mediarouter 1.0.0 移除了 media2 依赖项
  • 点击主屏幕按钮时,Fragment.getViewLifecycleOwner() 不会停止(公开问题 113070421

1.0.0-rc01

2018 年 8 月 6 日

此 AndroidX 候选版本被视为功能完备,而且其公共 API Surface 也稳定。除非出现任何严重问题,否则此版本将作为最终稳定版推出。此版本应可在生产环境中放心使用。如有任何问题,请向公开问题跟踪器报告。

修复的问题

  • BottomNavigationView 菜单未在设计支持库中正确初始化
  • PositionalDataSource 无法正确处理向数据库中插入前置项的操作
  • 滑块卡顿且无响应
  • SlicesProviderCompat.getPinnedSpecs() 不会将用户 ID 添加到 URI
  • RoutePlayer2:远程播放不会切换回本地播放
  • 缓存的切片解析在执行操作时崩溃
  • Google 搜索应用在渲染静态切片时崩溃
  • 当数据集随着移除选择而发生更改时 RecyclerView 选择库中出现 ConcurrentModificationException
  • PreferenceThemeOverlay 已更新为最新的素材主题背景。如果未提供自定义主题背景,则会将 PreferenceThemeOverlay 用作默认主题背景。
  • PreferenceThemeOverlay.v14 和 PreferenceThemeOverlay.v14.Material 主题背景已弃用,取而代之的是 PreferenceThemeOverlay。
  • PreferenceGroup 可见性现在与其子级相关联 - 如果隐藏父组,也会阻止其子级显示在层次结构中。使用 Preference.isShown() 可了解是否在层次结构中向用户实际显示了某项偏好设置。
  • Preference.onSetInitialValue(boolean, Object) 已弃用,取而代之的是 onSetInitialValue(Object)。此外,PreferenceDataStore 现在也可以正确恢复默认值。

1.0.0-beta01

2018 年 7 月 2 日

除非出现任何严重问题,否则此 AndroidX 测试版将被视为功能完备,而且其公共 API Surface 也稳定。虽然此版本可在生产环境中放心使用,但它可能仍有很多问题。如有任何问题,请向公开问题跟踪器报告。

修复的问题

  • 在不可选择的项上发生 GestureSelectionHelper 侵蚀事件
  • 更新滑块值时,滑块切片可能具有重复的拇指图标
  • IconCompat 破坏了 alpha3 中的 TYPE_URI 图标
  • 使用拖动条的偏好设置发生崩溃
  • Slice.toString() 中发生崩溃问题
  • OffsettingListUpdateCallback.onMoved() 会调用 mCallback.onRemoved() 而不是 mCallback.onMoved()(问题 110711937

影响 AndroidX 的 Android Studio 问题修复

  • 创建最低级别为 P 的项目时,gradle.properties 文件未更新为使用 AndroidX
  • 在 Windows 上启用了 AndroidX 的情况下,外部库无法编译(问题 79642238
  • 部署时转换的 androidx 应用发生崩溃
  • 无法解析:androidx.databinding:databinding-runtime:3.2.0-alpha16
  • 重构为 AndroidX 后无法部署渲染脚本应用
  • 执行“重构为 AndroidX”时发生崩溃
  • 错误:软件包 android.support.annotation 不存在
  • 在“重构为 AndroidX”期间,为 ConstraintLayout 类指定的类名称错误
  • 错误:软件包 android.support.design.R 不存在

1.0.0 alpha 3

2018 年 6 月 6 日

问题修复版本。

修复的问题

  • 如果打开了两个具有不同 AndroidX 依赖项的项目,RecyclerView 不会渲染
  • 如果 gradle.properties 不存在,项目无法创建和添加 androidx 标志
  • 缺少 androidx.core.media.MediaMetadataCompat
  • 大于 64K 时,切片会掉落
  • 切片浏览器发生崩溃
  • 在具有 androidX 依赖项的情况下,无法将应用迁移到 AppCompact
  • 数据绑定库未更新为 androidx
  • 单元格中的大图片会挡住其余单元格内容
  • 重构为 Androidx 时导入有误
  • SliceProviderCompat 中的切片因 NPE 而发生崩溃
  • 重构工具错误:不应使用与 compileSdkVersion (28) 不同的版本 (27)
  • 尝试构建重构的项目 (Android Sunflower) 时出现 Dex 合并问题
  • AndroidX 重构工具不会转换包含变量的依赖项
  • Espresso 测试记录器不支持 androidx 依赖项
  • com.example.androidx.slice.demos 中的 NPE
  • dejetifier flatfoot 问题
  • androidx.wear 对 ConstraintLayout 库的依赖关系错误
  • 完整加载的切片损坏
  • 重构为 androidx 后,添加新 Activity 时会使用旧支持代码创建该 Activity
  • dagger-android 无法与 jetifier 一起使用
  • 网格模板:网格行的缩略图的最小宽度为宽度与高度之比等于 1:1
  • 强制要求对切片执行主要操作
  • 设备音量的切片将要求对滑块配置 setMin
  • 权限切片损坏
  • 切片需要新的权限系统
  • 需要允许根据某项权限自动授予切片权限
  • 切片大小不一致
  • FontsContractCompat 中的 NullPointerException

1.0.0 alpha 2

2018 年 5 月 25 日

问题修复版本。

修复的问题

1.0.0 alpha 1

2018 年 5 月 8 日

初始 Alpha 版本。软件包名称在 Alpha 版期间可能会发生变化。

已知问题

  • 以下库与 AndroidX 重构尚不兼容:
    • com.google.dagger:dagger-android
    • com.google.android.support:wearable
    • io.fabric.tools:gradle:需要 1.25.4 或更高版本
  • 需要升级到版本 2.16 or later for,com.google.dagger:dagger-android 才能与 AndroidX 重构兼容。
  • Android Studio 重构工具错误地重构 android.arch.persistence.room.*android.support.v4.media.* 命名空间中的某些类。
    解决方法:运行重构工具后,检查并更正导入行。
  • 使用 Android Studio 重构工具后,即使已导入软件包,完整的软件包名称也会用于代码中的某些类。

修复的问题

  • BottomNavigationView 菜单未正确初始化(AOSP 问题 63375220
  • RecyclerView getItemDecorationAt 的文档错误(AOSP 问题 72727717