Mapa de compatibilidad de Compose para Kotlin

Cómo declarar dependencias

Para agregar una dependencia en el compilador de Compose, debes agregar el repositorio Maven de Google a tu proyecto. Lee el repositorio Maven de Google para obtener más información.

Agrega las dependencias de los artefactos que necesites en el archivo build.gradle de tu app o módulo:

Groovy

android {
    buildFeatures {
        compose true
    }

    composeOptions {
        kotlinCompilerExtensionVersion = "1.3.0"
    }

    kotlinOptions {
        jvmTarget = "1.8"
    }
}

Kotlin

android {
    buildFeatures {
        compose = true
    }

    composeOptions {
        kotlinCompilerExtensionVersion = "1.3.0"
    }

    kotlinOptions {
        jvmTarget = "1.8"
    }
}

Compatibilidad con Kotlin de versiones previas al lanzamiento

Para obtener información sobre las versiones del compilador de Compose compatibles con versiones previas al lanzamiento de Kotlin, consulta https://androidx.dev/storage/compose-compiler/repository.

Versión del compilador de Compose Versión de Kotlin compatible
1.3.0-beta01 1.7.10
1.2.0 1.7.0
1.2.0-rc02 1.6.21
1.2.0-rc01 1.6.21
1.2.0-beta03 1.6.21
1.2.0-beta02 1.6.21
1.2.0-beta01 1.6.21
1.2.0-alpha08 1.6.20
1.2.0-alpha07 1.6.10
1.2.0-alpha06 1.6.10
1.2.0-alpha05 1.6.10
1.2.0-alpha04 1.6.10
1.2.0-alpha03 1.6.10
1.2.0-alpha02 1.6.10
1.2.0-alpha01 1.6.10
1.1.1 1.6.10
1.1.0 1.6.10
1.1.0-rc03 1.6.10
1.1.0-rc02 1.6.10
1.1.0-rc01 1.6.0
1.1.0-beta04 1.6.0
1.1.0-beta03 1.5.31
1.1.0-beta02 1.5.31
1.1.0-beta01 1.5.31
1.1.0-alpha06 1.5.31
1.1.0-alpha05 1.5.31
1.0.5 1.5.31
1.0.4 1.5.31
1.1.0-alpha04 1.5.30
1.1.0-alpha03 1.5.30
1.0.3 1.5.30
1.1.0-alpha02 1.5.21
1.1.0-alpha01 1.5.21
1.0.2 1.5.21
1.0.1 1.5.21
1.0.0 1.5.10
1.0.0-rc02 1.5.10
1.0.0-rc01 1.5.10