Google Play 결제 라이브러리 버전 지원 중단

Google Play 결제 라이브러리 버전 3 소개 블로그 게시물에서 발표한 바와 같이 모든 신규 앱은 결제 라이브러리 버전 3 이상을 사용해야 합니다. 2021년 11월 1일까지 기존 앱의 모든 업데이트에 결제 라이브러리 버전 3 이상을 사용해야 합니다.

다음은 결제 라이브러리 버전 지원 중단 및 새 버전으로의 이전과 관련해 자주 묻는 질문의 답입니다.

지원 중단 경고가 표시되는 원인인 APK 또는 App Bundle을 찾으려면 어떻게 해야 하나요?
프로젝트에 가져온 종속 항목을 검토합니다(예: 프로젝트의 build.gradle 파일에 있는 종속 항목). 규정을 준수하려면 앱은 Play 결제 라이브러리 버전 3.0.0 이상을 가져와야 합니다. 결제 종속 항목은 com.android.vending.BILLING 권한이 필요한 APK에서만 찾을 수 있습니다.
더 이상 유지관리하지 않는 APK 또는 App Bundle에서 지원 중단된 Play 결제 라이브러리 버전을 사용합니다. 업데이트해야 하나요?
모든 APK를 최신 Play 결제 라이브러리 버전으로 업데이트할 것을 적극 권장합니다. 그러나 더 이상 유지관리하지 않는 APK의 경우 현재로서는 APK에 아무런 조치를 취하지 않아도 됩니다. 이번 지원 중단으로 인해 Play 결제 라이브러리 사용이 중단되는 항목은 신규 앱 및 업데이트뿐입니다. 지원 중단된 라이브러리 버전을 사용하는 기존 앱은 계속 정상적으로 작동합니다. 활발하게 유지관리되는 모든 APK가 업데이트되었는지 확인하세요.
APK 또는 App Bundle을 최신 Play 결제 라이브러리로 업데이트했는데도 지원 중단 경고가 계속 표시되는 문제를 해결하려면 어떻게 해야 하나요?
AndroidManifest.xml에 이름이 com.google.android.play.billingclient.version인 항목이 포함되어 있는지 확인합니다. 항목이 없으면 매니페스트 병합 설정에서 매니페스트 병합 중에 매니페스트 속성이 삭제되는지 확인하세요.
Play 결제 라이브러리 v2에서 v3으로 업그레이드하려면 어떻게 해야 하나요?
Play 결제 라이브러리 v3 이상을 사용하도록 버전의 종속 항목을 업데이트합니다. 출시 노트를 참고하여 버전 간의 변경사항을 확인하세요.
Play 결제 라이브러리 v1/AIDL에서 v3로 업그레이드하려면 어떻게 해야 하나요?
AIDL에서 업데이트하기 위한 이전 가이드를 참고하세요.
이 공지에 관한 자세한 내용은 어디에서 확인할 수 있나요?
자세한 내용은 Google Play 결제 라이브러리 버전 3 소개를 참고하세요.