lightbulb_outline Please take our October 2018 developer survey. Start survey

Wear OS 预览版设置

进行基本的兼容性测试时,您可以使用当前的 APK 和受支持的手表或模拟器。

无需为基本测试更新整个开发环境。如仅需测试应用与预览版系统镜像的兼容性,请参阅 Wear OS 预览版下载

但是,如需开发应用,您需要按下述方式更新开发环境。

安装 Android Studio 和最新软件包

  1. 为实现与 Android P 兼容,请安装最新版本的 Android Studio
  2. 使用 SDK 管理器进行安装,或确认您已安装了以下软件包的最新版本:
    • SDK Platform 标签下:Android P

更新或创建一个项目

要使用 API,您必须在 Android Studio 中恰当配置项目。

更新现有项目

要更新现有的开发项目,请按以下步骤操作:

  1. 启动 Android Studio,点击 Open an existing Android Studio Project,然后选择项目。
  2. 如果 Android SDK 管理器提示选择要用于该项目的 SDK 版本,请选择 Use Android Studio's SDK
  3. 如果系统提示更新 Gradle 插件,请更新插件版本。
  4. 在 Wear 模块的 build.gradle 文件中:
    • android 部分,将 compileSdkVersion 更新为“android-P”。
    • android 部分,将 targetSdkVersion 更新为“P”。
    • dependencies 部分,请将现有的对穿戴式支持库的引用更改为对以下内容的引用:compile 'com.google.android.support:wearable:2.3.0'

      此操作要求安装最新版本的 Google Repository。

  5. 请查看 Wear OS 预览版下载中的说明,设置包含预览版系统镜像的手表或模拟器,以便开始测试应用。

创建一个新项目

要创建新的开发项目,请按以下步骤操作:

  1. 点击 File > New Project,并按照“Create New Project”向导中的步骤操作,直到进入“Target Android Device”页面。
  2. 还可以选择 Phone and Tablet 选项。如果您计划在手机应用中使用 Android P API 和 Minimum SDK 选项列表,请选择 API P
  3. 选择 Wear 选项,并在 Minimum SDK 选项列表中选择可用的最新 (API P) 选项。点击 Next,直至退出“Create New Project”向导。
  4. 在 Wear 模块的 build.gradle 文件中:
    • android 部分,将 compileSdkVersion 更新为“android-P”。
    • android 部分,将 targetSdkVersion 更新为“P”。
    • dependencies 部分,请将现有的对穿戴式支持库的引用更改为对以下内容的引用:compile 'com.google.android.support:wearable:2.3.0'

      此操作要求安装最新版本的 Google Repository。

  5. 请查看 Wear OS 预览版下载中的说明,设置包含预览版系统镜像的手表或模拟器,以便开始测试应用。