SDK 플랫폼 출시 노트

이 페이지에서는 SDK ManagerSDK Platforms 탭에서 다운로드할 수 있는 SDK 패키지에 관한 출시 정보를 제공합니다.

각 SDK 플랫폼 버전에는 다음 패키지가 포함되어 있습니다.

  • Android SDK 플랫폼 패키지. 이는 해당 버전에 대해 앱을 컴파일하는 데 필요합니다.
  • 몇몇 시스템 이미지 패키지. Android Emulator에서 해당 버전을 실행하려면 적어도 이 패키지 중 하나가 필요합니다.

    각 플랫폼 버전에는 지원되는 폼 팩터(핸드셋, Android TV 및 Android Wear)별로 시스템 이미지가 포함되어 있습니다. 각 폼 팩터는 컴퓨터의 프로세서 아키텍처 (예: Intel x86 및 ARM EABI)와 일치하는 변형을 제공할 수 있습니다. Google API라는 라벨이 지정된 시스템 이미지에는 Google Play 서비스 액세스가 포함되어 있고 Google Play라는 라벨이 지정된 이미지에는 Google Play 스토어가 포함되어 있습니다.

  • Sources for Android 패키지. 여기에는 플랫폼의 소스 파일이 포함됩니다. 앱을 디버그하는 동안 Android 스튜디오에 이러한 파일의 코드 줄이 표시될 수 있습니다.

다음 섹션에 나열된 버전 번호는 Android SDK 플랫폼 패키지 전용입니다. 시스템 이미지는 일반적으로 에뮬레이터의 버그를 해결하기 위해 별도의 업데이트를 수신할 수 있습니다. 시스템 이미지에 관한 출시 노트는 없지만 항상 최신 상태로 유지해야 합니다.

Android 15 (개발자 프리뷰)

플랫폼 변경사항에 관한 자세한 내용은 Android 15 문서를 참고하세요.

Android 14 (API 수준 34)

플랫폼 변경사항에 관한 자세한 내용은 Android 14 문서를 참고하세요.

버전 1 (2023년 6월)

Android 14가 플랫폼 안정성 주요 시점에 도달하면 안정화 버전 채널 (더 이상 미리보기가 아님)으로 출시되었습니다.

Android 13(API 수준 33)

플랫폼 변경사항에 관한 자세한 내용은 Android 13 문서를 참고하세요.

버전 1 (2022년 6월)

Android 13이 플랫폼 안정성 주요 시점에 도달하면 안정화 버전 채널 (더 이상 미리보기가 아님)으로 출시되었습니다.

Android 12(API 수준 31, 32)

12L 기능 출시(API 수준 32)
플랫폼 변경사항에 관한 자세한 내용은 12L 문서를 참고하세요.

버전 1 (2022년 3월)

공개 버전 채널로 출시되었습니다 (더 이상 미리보기가 아님).

Android 12(API 수준 31)
플랫폼 변경사항에 관한 자세한 내용은 Android 12 문서를 참고하세요.

버전 1 (2021년 8월)

Android 12가 플랫폼 안정성 주요 시점에 도달하면 안정화 버전 채널 (더 이상 미리보기가 아님)으로 출시되었습니다.

Android 12 ATD 시스템 이미지

이 자동 테스트 기기 (ATD) 이미지는 헤드리스 자동 테스트에 최적화된 Android 시스템 이미지입니다. 초기 데이터에 따르면 이 이미지를 사용하는 테스트에서 에뮬레이터 프로세스 CPU 및 메모리 사용량이 감소하고 테스트 실제 경과 시간이 단축됩니다.

이러한 성능 향상은 다음과 같은 방법으로 이루어집니다.

  • 대부분의 사용자 대상 애플리케이션 삭제 (예: 다이얼러, 설정, SystemUI)
  • 하드웨어 렌더기를 통한 그리기 사용 중지

이미지에는 Google API를 제공하는 Google API ATD와 순수 AOSP 환경을 제공하는 AOSP ATD, 두 가지 버전이 있습니다.

ATD를 사용하여 테스트를 실행하는 방법에 관한 자세한 내용은 자동 테스트 기기를 사용한 테스트 실행을 참고하세요.

Android 11(API 수준 30)

플랫폼 변경사항에 관한 자세한 내용은 Android 11 문서를 참고하세요.

버전 1 (2020년 7월)

Android 11이 플랫폼 안정성 주요 시점에 도달했을 때 안정적인 채널 (더 이상 미리보기가 아님)으로 출시되었습니다.

Android 10(API 수준 29)

플랫폼 변경사항에 관한 자세한 내용은 개발자용 Android 10을 참고하세요.

버전 5(2020년 7월)

이 버전에서는 Android Automotive OS 스터브가 추가되었습니다.

Android 9(API 수준 28)

플랫폼 변경사항에 관한 자세한 내용은 개발자용 Android 9를 참고하세요.

버전 1(2018년 8월)

공개 버전 채널로 출시되었습니다 (더 이상 미리보기가 아님).

Android 8.1(API 수준 27)

플랫폼 변경사항에 관한 자세한 내용은 개발자용 Android 8.1을 참고하세요.

버전 1(2017년 12월)

공개 버전 채널로 출시되었습니다 (더 이상 미리보기가 아님).

Android 8.0(API 수준 26)

플랫폼 변경사항에 관한 자세한 내용은 개발자용 Android 8.0을 참고하세요.

버전 2(2017년 8월)

공개 버전 채널로 출시되었습니다 (더 이상 미리보기가 아님).

Android 7.1(API 수준 25)

플랫폼 변경사항에 관한 자세한 내용은 개발자용 Android 7.1을 참고하세요.

버전 3(2016년 12월)

증분 업데이트. 최종 Android 7.1.1로 출시되었습니다 (더 이상 미리보기가 아님).

종속 항목:

  • Android SDK 플랫폼 도구 25.0.1 이상이 필요합니다.
  • Android SDK 빌드 도구 25.0.1 이상이 필요합니다.

버전 2(2016년 11월)

증분 업데이트. Android 7.1.1 개발자 프리뷰 2로 출시되었습니다. 자세한 내용은 Android 7.1 API 개요를 참고하세요.

종속 항목:

  • Android SDK 플랫폼 도구 25.0.1 이상이 필요합니다.
  • Android SDK 빌드 도구 25.0.1 이상이 필요합니다.

버전 1(2016년 10월)

Android 7.1(API 수준 25)의 최초 버전. Android 7.1 개발자 프리뷰 1로 출시되었습니다. 자세한 내용은 Android 7.1 API 개요를 참고하세요.

종속 항목:

  • Android SDK 플랫폼 도구 25.0.0 이상이 필요합니다.
  • Android SDK 빌드 도구 25.0.0 이상이 필요합니다.

Android 7.0(API 수준 24)

플랫폼 변경사항에 관한 자세한 내용은 개발자용 Android 7.0을 참고하세요.

버전 1(2016년 8월)

Android 7.0(API 수준 24)의 최초 버전. 자세한 내용은 Android 7.0 API 개요를 참고하세요.

종속 항목:

  • Android SDK 플랫폼 도구 r24 이상이 필요합니다.
  • Android SDK 도구 24.0.0 이상이 필요합니다.

Android 6.0(API 수준 23)

플랫폼 변경사항에 관한 자세한 내용은 Android 6.0 변경사항Android 6.0 API를 참고하세요.

버전 2(2015년 11월)

Android 스튜디오에서 사용하는 레이아웃 렌더링 라이브러리의 버그가 수정되었습니다.

종속 항목:

  • Android SDK 플랫폼 도구 r23 이상이 필요합니다.
  • Android SDK 도구 24.3.4 이상이 필요합니다.

버전 1(2015년 8월)

Android 6.0(API 수준 23)의 최초 버전. 자세한 내용은 Android 6.0 API 개요를 참고하세요.

종속 항목:

  • Android SDK 플랫폼 도구 r23 이상이 필요합니다.
  • Android SDK 도구 24.3.4 이상이 필요합니다.

Android 5.1(API 수준 22)

플랫폼 변경사항에 관한 자세한 내용은 Lollipop 개요Android 5.1 API 변경사항을 참고하세요.

버전 1(2015년 3월)

Android 5.1(API 수준 22)의 최초 버전. 자세한 내용은 Android 5.1 API 개요를 참고하세요.

종속 항목:

  • Android SDK 플랫폼 도구 r22 이상이 필요합니다.
  • Android SDK 도구 23.0.5 이상이 필요합니다.

Android 5.0(API 수준 21)

플랫폼 변경사항에 관한 자세한 내용은 Lollipop 개요Android 5.0 API 변경사항을 참고하세요.

버전 2(2014년 12월)

지원 라이브러리의 레이아웃이 업데이트되고 여러 가지 문제가 수정되었습니다.

종속 항목:

  • Android SDK 플랫폼 도구 r21 이상이 필요합니다.
  • Android SDK 도구 23.0.5 이상이 필요합니다.

버전 1(2014년 10월)

Android 5.0(API 수준 21)의 최초 버전. 자세한 내용은 Android 5.0 API 개요를 참고하세요.

종속 항목:

  • Android SDK 플랫폼 도구 r21 이상이 필요합니다.
  • Android SDK 도구 23.0.5 이상이 필요합니다.

Android 4.4W(API 수준 20)

이 버전은 Android Wear에서 KitKat을 사용할 수 있게 해줍니다.

버전 2(2014년 10월)

렌더링 라이브러리가 업데이트되었습니다.

종속 항목:

  • Android SDK 플랫폼 도구 r20 이상이 필요합니다.
  • Android SDK 도구 23.0 이상이 필요합니다.

버전 1(2014년 6월)

Android Wear의 최초 릴리스

종속 항목:

  • Android SDK 플랫폼 도구 r20 이상이 필요합니다.
  • Android SDK 도구 23.0 이상이 필요합니다.

Android 4.4(API 수준 19)

플랫폼 변경사항에 관한 자세한 내용은 KitKat 개요Android 4.4 API 변경사항을 참고하세요.

버전 2(2013년 12월)

유지관리 버전. 시스템 버전은 4.4.2입니다. 자세한 내용은 Android 4.4 API 개요를 참고하세요.

종속 항목:
Android SDK 플랫폼 도구 r19 이상이 필요합니다.
Android SDK 도구 22.3 이상이 권장됩니다.

버전 1(2013년 10월)

최초 릴리스. 시스템 버전은 4.4입니다. 자세한 내용은 Android 4.4 API 개요를 참고하세요.

종속 항목:
Android SDK 플랫폼 도구 r19 이상이 필요합니다.
Android SDK 도구 22.3 이상이 권장됩니다.

Android 4.3(API 수준 18)

플랫폼 변경사항을 자세히 알아보려면 Jelly Bean 개요Android 4.3 API 변경사항을 참고하세요.

버전 2(2013년 8월)

유지관리 업데이트. 시스템 버전은 4.3입니다.

종속 항목:
Android SDK 플랫폼 도구 r18 이상이 필요합니다.
Android SDK 도구 22.0.4 이상이 권장됩니다.

버전 1(2013년 7월)

최초 버전. 시스템 버전은 4.3입니다.

종속 항목:
Android SDK 플랫폼 도구 r18 이상이 필요합니다.
Android SDK 도구 22.0.4 이상이 권장됩니다.

Android 4.2(API 수준 17)

플랫폼 변경사항을 자세히 알아보려면 Jelly Bean 개요Android 4.2 API 변경사항을 참고하세요.

버전 2(2013년 2월)

유지관리 업데이트. 시스템 버전은 4.2.2입니다.

종속 항목:
SDK 도구 r21 이상이 필요합니다.

버전 1(2012년 11월)

최초 버전. 시스템 버전은 4.2입니다.

종속 항목:
SDK 도구 r20 이상이 필요합니다.

Android 4.1(API 수준 16)

플랫폼 변경사항을 자세히 알아보려면 Jelly Bean 개요Android 4.1 API 변경사항을 참고하세요.

버전 3(2012년 10월)

유지관리 업데이트. 시스템 버전은 4.1.2입니다.

종속 항목:
SDK 도구 r20 이상이 필요합니다.

버전 2(2012년 7월)

유지관리 업데이트. 시스템 버전은 4.1.1입니다.

종속 항목:
SDK 도구 r20 이상이 필요합니다.

버전 1(2012년 6월)

최초 버전. 시스템 버전은 4.1.0입니다.

종속 항목:
SDK 도구 r20 이상이 필요합니다.

Android 4.0.3(API 수준 15)

버전 3(2012년 3월)

유지관리 업데이트. 시스템 버전은 4.0.4입니다.

참고: 이 시스템 이미지에는 SDK 도구 r17 이상과 함께 사용할 때 에뮬레이터 하드웨어 그래픽 가속에 관한 지원이 포함되어 있습니다. (추가 정보)

종속 항목:
SDK 도구 r17 이상이 필요합니다.

버전 2(2012년 1월)

유지관리 업데이트. 시스템 버전은 4.0.3입니다.

종속 항목:
SDK 도구 r14 이상이 필요합니다.

버전 1(2011년 12월)

최초 버전. 시스템 버전은 4.0.3입니다.

종속 항목:
SDK 도구 r14 이상이 필요합니다.

Android 4.0(API 수준 14)

Android 4.0, 버전 2(2011년 12월)

유지관리 업데이트. 시스템 버전은 4.0.2입니다.

종속 항목:
SDK 도구 r14 이상이 필요합니다.

Android 4.0, 버전 1(2011년 10월)

최초 버전. 시스템 버전은 4.0.1입니다.

종속 항목:
SDK 도구 r14 이상이 필요합니다.

Android 3.2(API 수준 13)

Android 3.2, 버전 1(2011년 7월)

최초 버전. SDK 도구 r12 이상이 권장됩니다.

Android 3.1(API 수준 12)

Android 3.1, 버전 3(2011년 7월)

종속 항목:

SDK 도구 r12 이상이 필요합니다.

참고:

ADT Eclipse 플러그인에서 시각적 레이아웃 편집기를 지원하도록 플랫폼의 렌더링 라이브러리가 개선되었습니다. 이 버전에서는 ADT에서 더 많은 그리기 기능이 허용되며 이전 렌더링 라이브러리의 몇 가지 버그가 수정되었습니다. 또한 ADT 12에 추가된 여러 편집기 기능을 사용할 수 있습니다.

Android 3.1, 버전 2(2011년 5월)

종속 항목:

SDK 도구 r11 이상이 필요합니다.

참고:

ADT에서 Android 3.1의 실행을 방해한 시각적 레이아웃 편집기 렌더링 라이브러리와 관련된 문제가 수정되었습니다.

Android 3.1, 버전 1(2011년 5월)

종속 항목:

SDK 도구 r11 이상이 필요합니다.

Android 3.0(API 수준 11)

Android 3.0, 버전 2(2011년 7월)

종속 항목:

SDK 도구 r12 이상이 필요합니다.

참고:

ADT Eclipse 플러그인에서 시각적 레이아웃 편집기를 지원하도록 플랫폼의 렌더링 라이브러리가 개선되었습니다. 이 버전에서는 ADT에서 더 많은 그리기 기능이 허용되며 이전 렌더링 라이브러리의 몇 가지 버그가 수정되었습니다. 또한 ADT 12에 추가된 여러 편집기 기능을 사용할 수 있습니다.

Android 3.0, 버전 1(2011년 2월)

종속 항목:

SDK 도구 r10 이상이 필요합니다.

Android 2.3.3(API 수준 10)

Android 2.3.3, 버전 2(2011년 7월)

종속 항목:

SDK 도구 r12 이상이 필요합니다.

참고:

ADT Eclipse 플러그인에서 시각적 레이아웃 편집기를 지원하도록 플랫폼의 렌더링 라이브러리가 개선되었습니다. 이 버전에서는 ADT에서 더 많은 그리기 기능이 허용되며 이전 렌더링 라이브러리의 몇 가지 버그가 수정되었습니다. 또한 ADT 12에 추가된 여러 편집기 기능을 사용할 수 있습니다.

Android 2.3.3, 버전 1(2011년 2월)

종속 항목:

SDK 도구 r9 이상이 필요합니다.

Android 2.3(API 수준 9)

Android 2.3, 버전 1(2010년 12월)

종속 항목:

SDK 도구 r8 이상이 필요합니다.