Android 5.1 API

컬렉션을 사용해 정리하기 내 환경설정을 기준으로 콘텐츠를 저장하고 분류하세요.

API 레벨: 22

Android 5.1(LOLLIPOP_MR1)은 사용자와 앱 개발자를 위한 새로운 기능을 제공하는 Lollipop 출시에 대한 업데이트입니다. 이 문서에서는 가장 주목할 새로운 API를 소개합니다.

새로운 플랫폼 기능을 개괄적으로 살펴보려면 Android Lollipop 하이라이트를 참조하세요.

대상 API 레벨 업데이트

Android 5.1용 앱의 빌드를 시작하려면 SDK Manager를 사용하여 Android 5.1 SDK 플랫폼과 시스템 이미지를 다운로드합니다. 그런 다음, targetSdkVersion "22"를 사용하도록 앱 개발 프로젝트를 설정합니다. Android 5.1 시스템에 대한 앱을 설치하여 테스트한 다음 이 변경과 함께 업데이트된 앱을 게시합니다.

minSdkVersion이 지원하지 않는 API를 실행하기 전에 시스템 API 레벨을 확인하는 조건을 코드에 추가하여 이전 버전을 지원하면서도 Android 5.1 API를 사용할 수 있습니다. 이전 버전과의 호환성을 유지하는 방법에 관한 자세한 정보를 보려면 다양한 플랫폼 버전 지원을 참조하세요.

API 레벨이 작동하는 방식에 관한 자세한 정보는 API 레벨이란?을 참조하세요.

여러 SIM 카드 지원

Android 5.1은 한 번에 두 개 이상의 모바일 이동통신사 SIM 카드 사용에 대한 지원을 추가합니다. 사용자는 이 기능을 이용해 두 개 이상의 SIM 카드 슬롯을 가진 기기에서 추가 SIM을 활성화할 수 있습니다.

현재의 네트워크를 통해 기기를 로밍할 것인지 여부를 포함해 SubscriptionManager 클래스를 통해 현재의 활성 SIM에 대한 정보에 액세스할 수 있습니다. 이 정보는 데이터 액세스 요금에 민감한 기기 사용자에 대해 앱의 데이터 액세스 출력을 낮추거나 끄고자 하는 개발자에게 유용합니다. READ_PHONE_STATE 권한을 요청하고 SubscriptionManager 객체의 SubscriptionManager.OnSubscriptionsChangedListener를 설정하여 기기의 현재 네트워크 연결 상태의 변경에 대해 앱에 경고할 수 있습니다.

지원 중단된 HTTP 클래스

Android 5.1에서는 org.apache.http 클래스와 android.net.http.AndroidHttpClient 클래스의 지원이 중단되었습니다. 이 클래스는 더 이상 유지되지 않으며, 이 API를 사용하는 앱 코드를 최대한 빠르게 URLConnection 클래스로 마이그레이션해야 합니다.

이동통신사 서비스

Android 5.1에서는 Android 기기에서 이동통신사 프로비저닝 작업을 수행할 수 있는 앱을 생성하도록 통신 서비스 제공업체에 대한 지원을 제공합니다. 이 API는 이동통신사 개발 앱이 이러한 작업을 수행하고 Google Play를 통해 배포될 수 있도록 안전하고 유연한 방법을 제공합니다. 기기의 UICC(Universal Integrated Circuit Card)에 있는 인증서와 일치하는 인증서를 사용하여 이 기능을 사용하는 앱에 서명해야 합니다.

이동통신사 서비스 API는 TelephonyManager 클래스, SmsManager 클래스 및 새로운 CarrierMessagingService 클래스에 추가되었습니다. 앱은 hasCarrierPrivileges() 메서드를 호출하여 이러한 API에 대한 액세스를 확인할 수 있습니다. 액세스 없이 이러한 API를 호출하는 앱은 SecurityException을 수신합니다.