Register now for Android Dev Summit 2019!

지원 라이브러리 설정

참고: Android 9.0(API 레벨 28)의 출시와 함께 Jetpack의 일부인 새로운 버전의 지원 라이브러리 AndroidX가 출시됩니다. AndroidX 라이브러리는 기존 지원 라이브러리를 포함하며 최신 Jetpack 구성요소 또한 포함합니다.

지원 라이브러리를 계속 사용할 수 있습니다. 이전 아티팩트(버전 27과 그 이전 버전 및 android.support.*로 패키징된 것)는 Google Maven에서 계속 사용할 수 있습니다. 그러나 모든 라이브러리 개발은 AndroidX 라이브러리에서 진행됩니다.

새로운 프로젝트에서 AndroidX 라이브러리를 사용하는 것이 좋습니다. 기존 프로젝트를 AndroidX로 이전하는 것 또한 고려해 보세요.

개발 프로젝트에서 Android 지원 라이브러리를 설정하는 방법은 사용할 기능과 애플리케이션으로 지원할 Android 플랫폼 버전 범위에 따라 다릅니다.

이 문서에서는 지원 라이브러리 패키지를 다운로드하고 개발 환경에 라이브러리를 추가하는 과정을 안내합니다.

지원 라이브러리는 이제 Google의 Maven 저장소를 통해서 사용할 수 있습니다. 더 이상 SDK 관리자를 통한 라이브러리 다운로드를 지원하지 않으며 이 기능은 곧 삭제됩니다.

지원 라이브러리 선택

지원 라이브러리를 애플리케이션에 추가하기 전에 포함할 기능과 지원할 가장 낮은 Android 버전을 결정하세요. 서로 다른 라이브러리가 제공하는 기능에 관해 자세히 알아보려면 지원 라이브러리 기능을 참조하세요.

지원 라이브러리 추가

지원 라이브러리를 사용하려면 개발 환경 내 애플리케이션 프로젝트의 클래스 경로 종속성을 수정해야 합니다. 사용할 지원 라이브러리마다 이 절차를 진행해야 합니다.

지원 라이브러리를 애플리케이션 프로젝트에 추가하려면 다음 단계를 따르세요.

  1. 최상위 build.gradle 파일에 Google의 Maven 저장소를 포함합니다.
        allprojects {
            repositories {
                google()
    
                // If you're using a version of Gradle lower than 4.1, you must
                // instead use:
                //
                // maven {
                //     url 'https://maven.google.com'
                // }
            }
        }
        
  2. dependencies 섹션에 지원 라이브러리를 추가합니다. 예를 들어, v4 core-utils 라이브러리를 추가하려면 다음 행을 추가합니다.
        dependencies {
            ...
            implementation "com.android.support:support-core-utils:28.0.0"
        }
        

주의: palette-v7:23.0.+와 같은 동적 종속성을 사용하면 예상치 못한 버전 업데이트 및 회귀 비호환성이 발생할 수 있습니다. palette-v7:28.0.0처럼 명시적으로 라이브러리 버전을 지정하는 것이 좋습니다.

지원 라이브러리 API 사용

기존 프레임워크 API를 지원하는 지원 라이브러리 클래스는 일반적으로 프레임워크 클래스와 같은 이름을 가지고 있으나 android.support 클래스 패키지에 위치하거나 *Compat 접미사가 붙습니다.

주의: 지원 라이브러리의 클래스를 사용하는 경우 적절한 패키지에서 클래스를 가져와야 합니다. 예를 들어, ActionBar 클래스를 적용하는 경우 다음과 같이 해야 합니다.

  • 지원 라이브러리 사용 시 android.support.v7.app.ActionBar
  • API 레벨 11 이상에서만 개발 시 android.app.ActionBar

참고: 애플리케이션 프로젝트에 지원 라이브러리를 포함한 후 ProGuard 도구를 사용하여 애플리케이션 APK 버전을 준비하는 것이 좋습니다. ProGuard 도구는 소스 코드를 보호할 뿐만 아니라, 애플리케이션에 포함된 라이브러리에서 사용되지 않는 클래스를 제거하여 애플리케이션의 다운로드 크기를 최소한으로 만듭니다. 자세한 내용은 ProGuard를 참조하세요.

일부 지원 라이브러리 기능 사용에 대한 더 자세한 안내는 Android 개발자 학습 클래스, 가이드 및 샘플에서 제공합니다. 개별 지원 라이브러리 클래스 및 방식에 대한 자세한 내용은 API 참조의 android.support 패키지를 참조하세요.

매니페스트 선언 변경

지원 라이브러리를 사용하여 기존 애플리케이션의 이전 Android API 버전에 대한 호환성을 향상시키려면 애플리케이션의 매니페스트를 업데이트해야 합니다. 특히, 매니페스트 <uses-sdk> 태그의 android:minSdkVersion 요소를 아래와 같이 새로운 더 하위 버전 숫자로 업데이트해야 합니다.

      <uses-sdk
          android:minSdkVersion="14"
          android:targetSdkVersion="23" />
    

이 매니페스트 설정은 애플리케이션이 Android 4.0(API 레벨 14) 이상 기기에 설치될 수 있음을 Google Play에 알립니다.

Gradle 빌드 파일을 사용하는 경우 빌드 파일의 minSdkVersion 설정이 매니페스트 설정을 재정의합니다.

    apply plugin: 'com.android.application'

    android {
        ...

        defaultConfig {
            minSdkVersion 16
            ...
        }
        ...
    }
    

이 경우 빌드 파일 설정은 애플리케이션의 기본 빌드 변형이 Android 4.1(API 레벨 16) 이상 기기에 설치될 수 있음을 Google Play에 알립니다. 빌드 변형에 대한 자세한 내용은 빌드 시스템 개요를 참조하세요.

참조: 지원 라이브러리를 여러 개 추가하는 경우 최소 SDK 버전은 명시된 라이브러리가 요구하는 최상위 버전이어야 합니다. 예를 들어 앱에 v14 환경설정 지원 라이브러리v17 Leanback 라이브러리가 포함되는 경우, 최소 SDK 버전은 17 이상이어야 합니다.