Android Gradle 플러그인 출시 노트

컬렉션을 사용해 정리하기 내 환경설정을 기준으로 콘텐츠를 저장하고 분류하세요.
JCenter 저장소는 2021년 3월 31일 읽기 전용으로 변경되었습니다. 자세한 내용은 JCenter 서비스 업데이트를 참고하세요.

Android 스튜디오 빌드 시스템은 Gradle을 기반으로 하며 Android Gradle 플러그인에는 Android 앱을 빌드하는 데 사용하는 몇 가지 추가 기능이 있습니다. Android 플러그인은 일반적으로 Android 스튜디오와 완전히 동기화되어 업데이트되지만, 나머지 Gradle 시스템과 함께 Android 스튜디오로부터 독립적으로 실행되고 별도로 업데이트될 수도 있습니다.

이 페이지에서는 Gradle 도구를 업데이트하는 방법과 최근 업데이트 내용을 설명합니다. 이전 Android Gradle 플러그인 버전의 출시 노트는 이전 출시 노트를 참고하세요.

Android Gradle 플러그인의 예정된 브레이킹 체인지를 개략적으로 알아보려면 Android Gradle 플러그인 로드맵을 참고하세요.

Gradle을 사용하여 Android 빌드를 구성하는 방법에 관한 자세한 내용은 다음 페이지를 참고하세요.

Gradle 빌드 시스템에 관한 자세한 내용은 Gradle 사용자 가이드를 참고하세요.

Android Gradle 플러그인 업데이트

Android 스튜디오를 업데이트하면 Android Gradle 플러그인을 사용 가능한 최신 버전으로 자동 업데이트하라는 메시지가 표시될 수 있습니다. 업데이트를 수락하거나 프로젝트의 빌드 요구사항에 따라 버전을 수동으로 지정할 수 있습니다.

Android 스튜디오의 File > Project Structure > Project 메뉴 또는 최상위 build.gradle 파일에서 플러그인 버전을 지정할 수 있습니다. 플러그인 버전은 Android 스튜디오 프로젝트에 빌드된 모든 모듈에 적용됩니다. 다음 예는 build.gradle 파일에서 플러그인을 버전 7.3.0으로 설정합니다.

Groovy

plugins {
    id 'com.android.application' version '7.3.0' apply false
    id 'com.android.library' version '7.3.0' apply false
    id 'org.jetbrains.kotlin.android' version '1.5.31' apply false
}

Kotlin

plugins {
    id("com.android.application") version "7.3.0" apply false
    id("com.android.library") version "7.3.0" apply false
    id("org.jetbrains.kotlin.android") version "1.5.31" apply false
}

주의: 버전 번호에 동적 종속 항목을 사용해서는 안 됩니다(예: 'com.android.tools.build:gradle:2.+'). 이 기능을 사용하면 예상하지 못한 버전 업데이트가 발생할 수 있고 버전 차이를 확인하기 어려울 수 있습니다.

지정된 플러그인 버전을 다운로드하지 않은 경우, 다음에 프로젝트를 빌드할 때 또는 Android 스튜디오 메뉴 바에서 File > Sync Project with Gradle Files를 클릭하면 Gradle에서 지정된 버전의 플러그인을 다운로드합니다.

Gradle 업데이트

Android 스튜디오를 업데이트하면 Gradle 또한 사용 가능한 최신 버전으로 업데이트하라는 메시지가 표시될 수 있습니다. 업데이트를 수락하거나 프로젝트의 빌드 요구사항에 따라 버전을 수동으로 지정할 수 있습니다.

다음 표는 각 버전의 Android Gradle 플러그인에 필요한 Gradle 버전을 보여줍니다. 최상의 성능을 위해서는 Gradle과 플러그인을 가능한 최신 버전으로 사용해야 합니다.

플러그인 버전필요한 최소 Gradle 버전
8.08.0
7.47.5
7.37.4
7.27.3.3
7.17.2
7.07.0
4.2.0+6.7.1

이전 버전

플러그인 버전필요한 Gradle 버전
4.1.0+6.5+
4.0.0+6.1.1+
3.6.0~3.6.45.6.4+
3.5.0~3.5.45.4.1+
3.4.0~3.4.35.1.1+
3.3.0~3.3.34.10.1+
3.2.0~3.2.14.6+
3.1.0+4.4+
3.0.0+4.1+
2.3.0+3.3+
2.1.3~2.2.32.14.1~3.5
2.0.0~2.1.22.10~2.13
1.5.02.2.1~2.13
1.2.0~1.3.12.2.1~2.9
1.0.0~1.1.32.2.1~2.3

Android 스튜디오의 File > Project Structure > Project 메뉴에서 Gradle 버전을 지정하거나 명령줄을 사용하여 Gradle 버전을 업데이트할 수 있습니다. 선호되는 방법은 Gradle Wrapper 명령줄 도구를 사용하여 gradlew 스크립트를 업데이트하는 것입니다. 다음 예는 Gradle Wrapper를 사용하여 Gradle 버전을 7.5.1로 설정합니다. Gradle과 Gradle Wrapper 자체를 모두 업그레이드하려면 이 명령어를 두 번 실행해야 합니다(자세한 내용은 Gradle Wrapper 업그레이드 참고).

./gradle wrapper --gradle-version --7.5.1

그러나 AGP를 업데이트했는데 더 이상 현재 Gradle 버전과 호환되지 않는 등의 일부 경우에는 실패할 수 있습니다. 이 경우 gradle/wrapper/gradle-wrapper.properties 파일에서 Gradle 배포 참조를 수정해야 합니다. 다음 예는 gradle-wrapper.properties 파일에서 Gradle 버전을 7.5.1로 설정합니다.

...
distributionUrl = "https\://services.gradle.org/distributions/gradle-7.5.1-bin.zip"
...

Android Gradle 플러그인과 Android 스튜디오 호환성

Android 스튜디오 빌드 시스템은 Gradle을 기반으로 하며 Android Gradle 플러그인에는 Android 앱을 빌드하는 데 사용하는 몇 가지 추가 기능이 있습니다. 다음 표에는 각 버전의 Android 스튜디오에 필요한 Android Gradle 플러그인 버전이 나열되어 있습니다.

Android 스튜디오 버전 필요한 플러그인 버전
Flamingo | 2022.2.1 3.2~8.0
Electric Eel | 2022.1.1 3.2~7.4
Dolphin | 2021.3.1 3.2~7.3
Chipmunk | 2021.2.1 3.2~7.2
Bumblebee | 2021.1.1 3.2~7.1
Arctic Fox | 2020.3.1 3.1~7.0

Android Gradle 플러그인의 새로운 기능에 관한 정보는 Android Gradle 플러그인 출시 노트를 참고하세요.

버전 관리 변경사항(2020년 11월)

기본 Gradle 빌드 도구와 더 일치하도록 Android Gradle 플러그인(AGP)의 버전 번호 체계가 업데이트되었습니다.

주요 변경사항은 다음과 같습니다.

  • 이제 AGP는 시맨틱 버전 관리를 사용하고, 주요 버전에는 브레이킹 체인지가 타겟팅됩니다.

  • Gradle 메이저 버전에 맞춘 AGP 메이저 버전이 매년 1회 출시될 예정입니다.

  • AGP 4.2 이후 출시되는 버전은 7.0이며 Gradle 버전 7.x로 업그레이드해야 합니다. AGP의 모든 메이저 버전에는 기본 Gradle 도구의 메이저 버전 업그레이드가 필요합니다.

  • API는 1년 정도 미리 지원 중단될 예정이며 이를 대체하는 기능이 곧바로 제공됩니다. 지원 중단된 API는 약 1년 후, 다음 주요 업데이트 동안 삭제됩니다.

7.3.0(2022년 9월)

Android Gradle 플러그인 7.3.0은 다양한 새 기능과 개선사항이 포함된 메이저 버전입니다.

호환성

최소 버전 기본 버전 참고
Gradle 7.4 7.4 자세한 내용은 Gradle 업데이트하기를 참고하세요.
SDK 빌드 도구 30.0.3 30.0.3 SDK 빌드 도구를 설치 또는 구성합니다.
NDK 해당 사항 없음 23.1.7779620 다른 버전의 NDK를 설치 또는 구성합니다.
JDK 11 11 자세한 내용은 JDK 버전 설정을 참고하세요.

맞춤 C/C++ 빌드 시스템 지원

이제 Ninja 빌드 파일 형식으로 빌드 정보를 작성하는 셸 스크립트를 만들어서 맞춤 C/C++ 빌드 시스템을 생성할 수 있습니다. 맞춤 C/C++ 빌드 시스템에 관한 자세한 내용은 Ninja를 사용하여 맞춤 C/C++ 빌드 시스템 통합(실험용)을 참고하세요.

맞춤 C/C++ 빌드 시스템 스크린샷

Kotlin 플러그인의 최소 버전은 1.5.20임

Android Gradle 플러그인 7.3.0-alpha08부터 AGP에 Kotlin 플러그인 1.5.20 이후 버전이 필요합니다. 호환성을 유지하려면 build.gradle 파일에서 Kotlin 플러그인 1.5.20 이후 버전을 지정해야 합니다.

org.jetbrains.kotlin:kotlin-gradle-plugin:1.5.20

보관처리된 APK 생성 사용 설정됨

AGP 7.3부터 빌드된 모든 Android App Bundle에서 스토어 보관 파일이 기본적으로 사용 설정됩니다. 보관처리는 향후 저장용량이 부족한 사용자가 앱 공간을 효과적으로 관리할 수 있는(스토어에서 지원되는 경우) 새로운 App Bundle 기능입니다.

보관처리된 APK의 생성을 선택 해제하려면 다음과 같이 앱 수준 build.gradle 파일을 수정합니다.

android {
  bundle {
    storeArchive {
      enable = false
    }
  }
}

매니페스트 파일의 패키지 속성이 지원 중단됨

AGP 7.3.0-alpha04부터 Gradle을 사용하여 프로젝트를 빌드할 때 매니페스트 파일에서 package 속성을 사용하면 AGP에서 경고가 생성됩니다. 앱의 네임스페이스를 설정하려면 모듈 수준 build.gradle 파일에서 namespace 속성을 사용하세요. 자세한 내용은 네임스페이스 설정을 참고하세요.

새로운 네임스페이스 DSL로 이전하는 데 도움이 필요하면 AGP 업그레이드 어시스턴트(도구 > AGP 업그레이드 어시스턴트)를 사용하세요.

Android 플랫폼 지원

AGP 7.3.0-beta05부터 지원되는 최소 SDK 버전은 33입니다(minSdk = 33 사용 가능). 최소 SDK는 앱을 실행할 수 있는 최소 버전의 Android를 나타내며 앱 수준 build.gradle 파일에 설정됩니다.