Participe do evento ⁠#Android11: apresentação de lançamento da versão Beta no dia 3 de junho.

Próximos prazos para Android e Google Play

Nossa plataforma e nossas políticas estão em constante evolução para melhorar a experiência do usuário e criar um ecossistema mais seguro. Use esta página para ficar atualizado sobre as alterações necessárias e encontrar informações adicionais. Agradecemos por manter seus apps e jogos atualizados.

Prazo

policy timeline policy timeline

Mudanças em destaque

Migre para a API Play Install Referrer

Os desenvolvedores que dependem da transmissão da intent do referenciador de instalação para acompanhar as instalações do app precisam migrar para a API Play Install Referrer até 1º de março de 2020. Em muitos casos, a intent é usada por SDKs de terceiros que fornecem análises e acompanham o desempenho de campanhas de marketing, como o AppsFlyer e o Kochava. Nesses casos, nenhuma ação é necessária por parte dos desenvolvedores, porque esses parceiros já são compatíveis com a nova API Play Install Referrer.

Migre as tarefas em segundo plano para o WorkManager

Em abril de 2020, a biblioteca FirebaseJobDispatcher será arquivada, e não prestaremos mais suporte em caso de problemas registrados sobre ela. A biblioteca GCMNetworkManager não está mais recebendo novos recursos. A partir de novembro de 2020, não prestaremos mais suporte em caso de problemas relacionados a ela. Depois que o app atualizar o nível desejado da API (targetSdkVersion) para Android 10 (nível 29 da API), as chamadas de API de FirebaseJobDispatcher e GcmNetworkManager não funcionarão mais em dispositivos com Android Marshmallow (6.0) e posteriores.

Compatibilidade obrigatória com 64 bits

A partir de 1º de agosto de 2019, os apps e jogos publicados no Google Play precisarão ser compatíveis com ABIs de 64 bits das arquiteturas de 32 bits correspondentes. Os apps e jogos que usam o SDK Corona Labs ou o software Adobe Air e o SDK Air têm até o dia 1º de agosto de 2020. Os jogos criados com Unity 5.6.7 e versões anteriores têm até 1º de agosto de 2021.

Os apps precisam ser criados para o nível 29 da API

O APK enviado por você precisa atender aos requisitos de nível de API do Google Play. Até 3 de agosto de 2020, os apps novos precisarão ser criados pelo menos para o Android 10 (nível 29 da API). A partir de 2 de novembro de 2020, todos os apps que estiverem sendo atualizados precisarão estar em conformidade com o Android 10 (nível 29 da API), no mínimo. Antes dessas datas, os novos apps e as atualizações precisarão ser adequados ao Android 9 (nível 28 da API), no mínimo.

Migre para a biblioteca do Google Play Faturamento 2.0

A partir de 1º de maio de 2021, a biblioteca do Google Play Faturamento 2.0 será exigida de todos os apps novos e atualizações que usarem esse recurso.

Compatibilidade com o Android 10

Atualize seus apps para o Android 10, com proteções mais fortes para a privacidade do usuário, novas maneiras de engajamento, compatibilidade estendida para dispositivos dobráveis, extensões Vulkan e muito mais.

Prazos anteriores

Desative a monetização de vídeos na página "Detalhes do app"

Fizemos algumas alterações na maneira como os vídeos aparecem na Play Store em 1º de novembro de 2019. Como parte dessa atualização, todos os vídeos monetizados do YouTube nos detalhes do app podem começar a exibir anúncios, o que pode confundir e distrair os usuários. Se você não desativar os anúncios até essa data, o vídeo não será mais exibido no Google Play.

Obedeça a atualização de novembro da política do Google Play

Em 13 de novembro de 2019, atualizamos nossas políticas sobre vários tópicos, incluindo declarações enganosas, metadados, spam e certificação de rede de publicidade. Todos os apps precisam estar em conformidade no momento da publicação.

Migre para a API Google Play Developer v3

Desde 1º de dezembro de 2019, as versões 1 e 2 da API Google Play Developer, usadas para gerenciar publicações e compras no aplicativo, não estão mais disponíveis. Faça a atualização para a versão 3 caso ainda não tenha feito isso.