Menyiapkan Android 15 SDK

Untuk mengembangkan aplikasi dengan Android 15 API dan menguji aplikasi dengan perubahan perilaku Android 15, Anda harus menyiapkan Android 15 SDK. Ikuti petunjuk di halaman ini untuk menyiapkan Android 15 SDK di Android Studio serta membuat dan menjalankan aplikasi di Android 15.

Dapatkan Android Studio

Android 15 SDK menyertakan perubahan yang tidak kompatibel dengan beberapa versi Android Studio yang lebih rendah. Untuk mendapatkan pengalaman pengembangan terbaik dengan Android 15 SDK, gunakan versi pratinjau terbaru Android Studio. Perlu diingat bahwa Anda dapat mempertahankan versi Android Studio yang telah diinstal karena Anda dapat menginstal beberapa versi secara berdampingan.

Mendapatkan Android Studio

Menginstal SDK

Dalam Android Studio, Anda dapat menginstal Android 15 SDK sebagai berikut:

  1. Klik Tools > SDK Manager.
  2. Di tab SDK Platforms, luaskan bagian Android VanillaIceCream Preview dan pilih paket Android SDK Platform VanillaIceCream.
  3. Di tab SDK Tools, luaskan bagian Android SDK Build-Tools 35 dan pilih versi 35.x.x terbaru. Label ini mungkin memiliki akhiran seperti rc1 atau rc2.
  4. Klik OK untuk menginstal SDK.

Mengupdate konfigurasi build aplikasi Anda

Untuk mengakses API Android 15 dan menguji kompatibilitas aplikasi Anda dengan Android 15, buka file build.gradle atau build.gradle.kts tingkat modul, lalu update dengan nilai untuk Android 15. Cara Anda memformat nilai bergantung pada versi plugin Android Gradle (AGP) yang Anda gunakan.

AGP 7.0.0 atau yang lebih tinggi

Jika Anda menggunakan AGP 7.0.0 atau yang lebih tinggi, update file build.gradle atau build.gradle.kts aplikasi Anda dengan nilai berikut pada Android 15:

Groovy

android {
    compileSdkPreview "VanillaIceCream"
    ...
    defaultConfig {
        targetSdkPreview "VanillaIceCream"
    }
}

Kotlin

android {
    compileSdkPreview = "VanillaIceCream"
    ...
    defaultConfig {
        targetSdkPreview = "VanillaIceCream"
    }
}

AGP 4.2.0 atau yang lebih rendah

Jika Anda menggunakan AGP 4.2.0 atau yang lebih rendah, update file build.gradle atau build.gradle.kts aplikasi Anda dengan nilai berikut pada Android 15:

Groovy

android {
    compileSdkVersion "android-VanillaIceCream"
    ...
    defaultConfig {
        targetSdkVersion "android-VanillaIceCream"
    }
}

Kotlin

android {
    compileSdkVersion = "android-VanillaIceCream"
    ...
    defaultConfig {
        targetSdkVersion = "android-VanillaIceCream"
    }
}