Skip to content

Most visited

Recently visited

navigation
DrawableTinting / res / values /

base-strings.xml

1
<?xml version="1.0" encoding="UTF-8"?>
2
<!--
3
 Copyright 2013 The Android Open Source Project
4
 
5
 Licensed under the Apache License, Version 2.0 (the "License");
6
 you may not use this file except in compliance with the License.
7
 You may obtain a copy of the License at
8
 
9
     http://www.apache.org/licenses/LICENSE-2.0
10
 
11
 Unless required by applicable law or agreed to in writing, software
12
 distributed under the License is distributed on an "AS IS" BASIS,
13
 WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
14
 See the License for the specific language governing permissions and
15
 limitations under the License.
16
-->
17
 
18
<resources>
19
    <string name="app_name">DrawableTinting</string>
20
    <string name="intro_message">
21
        <![CDATA[
22
         
23
             
24
            Sample that shows applying tinting and color filters to Drawables both programmatically
25
            and as Drawable resources in XML.
26
            \n\nTinting is set on a nine-patch drawable through the "tint" and "tintMode" parameters.
27
            A color state list is referenced as the tint color, which defines colors for different
28
            states of a View (for example disabled/enabled, focused, pressed or selected).
29
            \n\nProgrammatically, tinting is applied to a Drawable through its "setColorFilter" method,
30
            with a reference to a color and a PorterDuff blend mode. The color and blend mode can be
31
            changed from the UI to see the effect of different options.
32
             
33
         
34
        ]]>
35
    </string>
36
</resources>
This site uses cookies to store your preferences for site-specific language and display options.

Get the latest Android developer news and tips that will help you find success on Google Play.

* Required Fields

Hooray!

Follow Google Developers on WeChat

Browse this site in ?

You requested a page in , but your language preference for this site is .

Would you like to change your language preference and browse this site in ? If you want to change your language preference later, use the language menu at the bottom of each page.

This class requires API level or higher

This doc is hidden because your selected API level for the documentation is . You can change the documentation API level with the selector above the left navigation.

For more information about specifying the API level your app requires, read Supporting Different Platform Versions.

Take a short survey?
Help us improve the Android developer experience.
(Sep 2017 survey)