Added in [API level 1](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

# javax.security.auth.x500

This package contains the classes that should be used to store X500 Principal and X500 Private Credentials in a *Subject*.

## Package Specification

- [RFC 1779: A String Representation of Distinguished Names](http://www.ietf.org/rfc/rfc1779.txt)
- [RFC 2253: Lightweight Directory Access Protocol (v3): UTF-8 String Representation of Distinguished Names](http://www.ietf.org/rfc/rfc2253.txt)
- [RFC 3280: Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) Profile](http://www.ietf.org/rfc/rfc3280.txt)
- [RFC 4512: Lightweight Directory Access Protocol (LDAP): Directory Information Models](http://www.ietf.org/rfc/rfc4512.txt)

## Classes

|---|---|
| [X500Principal](https://developer.android.com/reference/javax/security/auth/x500/X500Principal) | This class represents an X.500 `Principal`. |
| [X500PrivateCredential](https://developer.android.com/reference/javax/security/auth/x500/X500PrivateCredential) | This class represents an `X500PrivateCredential`. |

-

  ## Classes

  - [X500Principal](https://developer.android.com/reference/javax/security/auth/x500/X500Principal)
  - [X500PrivateCredential](https://developer.android.com/reference/javax/security/auth/x500/X500PrivateCredential)