Added in [API level 1](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels) Summary: [Constants](https://developer.android.com/reference/java/security/Key#constants) \| [Methods](https://developer.android.com/reference/java/security/Key#pubmethods)

# Key

` public interface Key `   
` implements https://developer.android.com/reference/java/io/Serializable `

|---|
| java.security.Key |

Known indirect subclasses [DHPrivateKey](https://developer.android.com/reference/javax/crypto/interfaces/DHPrivateKey), [DHPublicKey](https://developer.android.com/reference/javax/crypto/interfaces/DHPublicKey), [DSAPrivateKey](https://developer.android.com/reference/java/security/interfaces/DSAPrivateKey), [DSAPublicKey](https://developer.android.com/reference/java/security/interfaces/DSAPublicKey), [ECPrivateKey](https://developer.android.com/reference/java/security/interfaces/ECPrivateKey), [ECPublicKey](https://developer.android.com/reference/java/security/interfaces/ECPublicKey), [EdECPrivateKey](https://developer.android.com/reference/java/security/interfaces/EdECPrivateKey), [EdECPublicKey](https://developer.android.com/reference/java/security/interfaces/EdECPublicKey), [PBEKey](https://developer.android.com/reference/javax/crypto/interfaces/PBEKey), [PrivateKey](https://developer.android.com/reference/java/security/PrivateKey), [PublicKey](https://developer.android.com/reference/java/security/PublicKey), [RSAMultiPrimePrivateCrtKey](https://developer.android.com/reference/java/security/interfaces/RSAMultiPrimePrivateCrtKey), [RSAPrivateCrtKey](https://developer.android.com/reference/java/security/interfaces/RSAPrivateCrtKey), [RSAPrivateKey](https://developer.android.com/reference/java/security/interfaces/RSAPrivateKey), [RSAPublicKey](https://developer.android.com/reference/java/security/interfaces/RSAPublicKey), [SecretKey](https://developer.android.com/reference/javax/crypto/SecretKey), [SecretKeySpec](https://developer.android.com/reference/javax/crypto/spec/SecretKeySpec), [XECPrivateKey](https://developer.android.com/reference/java/security/interfaces/XECPrivateKey), [XECPublicKey](https://developer.android.com/reference/java/security/interfaces/XECPublicKey) [DHPrivateKey](https://developer.android.com/reference/javax/crypto/interfaces/DHPrivateKey) The interface to a Diffie-Hellman private key. [DHPublicKey](https://developer.android.com/reference/javax/crypto/interfaces/DHPublicKey) The interface to a Diffie-Hellman public key. [DSAPrivateKey](https://developer.android.com/reference/java/security/interfaces/DSAPrivateKey) The standard interface to a DSA private key. [DSAPublicKey](https://developer.android.com/reference/java/security/interfaces/DSAPublicKey) The interface to a DSA public key. [ECPrivateKey](https://developer.android.com/reference/java/security/interfaces/ECPrivateKey) The interface to an elliptic curve (EC) private key. [ECPublicKey](https://developer.android.com/reference/java/security/interfaces/ECPublicKey) The interface to an elliptic curve (EC) public key. [EdECPrivateKey](https://developer.android.com/reference/java/security/interfaces/EdECPrivateKey) An interface for an elliptic curve private key as defined by [RFC 8032: Edwards-Curve Digital Signature Algorithm (EdDSA)](https://tools.ietf.org/html/rfc8032). [EdECPublicKey](https://developer.android.com/reference/java/security/interfaces/EdECPublicKey) An interface for an elliptic curve public key as defined by [RFC 8032: Edwards-Curve Digital Signature Algorithm (EdDSA)](https://tools.ietf.org/html/rfc8032). [PBEKey](https://developer.android.com/reference/javax/crypto/interfaces/PBEKey) The interface to a PBE key. [PrivateKey](https://developer.android.com/reference/java/security/PrivateKey) A private key. [PublicKey](https://developer.android.com/reference/java/security/PublicKey) A public key.
[RSAMultiPrimePrivateCrtKey](https://developer.android.com/reference/java/security/interfaces/RSAMultiPrimePrivateCrtKey) The interface to an RSA multi-prime private key, as defined in the [PKCS#1 v2.2](https://tools.ietf.org/rfc/rfc8017.txt) standard, using the *Chinese Remainder Theorem* (CRT) information values. [RSAPrivateCrtKey](https://developer.android.com/reference/java/security/interfaces/RSAPrivateCrtKey) The interface to an RSA private key, as defined in the [PKCS#1 v2.2](https://tools.ietf.org/rfc/rfc8017.txt) standard, using the *Chinese Remainder Theorem* (CRT) information values. [RSAPrivateKey](https://developer.android.com/reference/java/security/interfaces/RSAPrivateKey) The interface to an RSA private key. [RSAPublicKey](https://developer.android.com/reference/java/security/interfaces/RSAPublicKey) The interface to an RSA public key. [SecretKey](https://developer.android.com/reference/javax/crypto/SecretKey) A secret (symmetric) key. [SecretKeySpec](https://developer.android.com/reference/javax/crypto/spec/SecretKeySpec) This class specifies a secret key in a provider-independent fashion. [XECPrivateKey](https://developer.android.com/reference/java/security/interfaces/XECPrivateKey) An interface for an elliptic curve private key as defined by RFC 7748. [XECPublicKey](https://developer.android.com/reference/java/security/interfaces/XECPublicKey) An interface for an elliptic curve public key as defined by RFC 7748.   

*** ** * ** ***

The Key interface is the top-level interface for all keys. It defines the functionality shared by all key objects. All keys have three characteristics:

- An Algorithm This is the key algorithm for that key. The key algorithm is usually an encryption or asymmetric operation algorithm (such as DSA or RSA), which will work with those algorithms and with related algorithms (such as MD5 with RSA, SHA-1 with RSA, Raw DSA, etc.) The name of the algorithm of a key is obtained using the `https://developer.android.com/reference/java/security/Key#getAlgorithm()` method.

- An Encoded Form This is an external encoded form for the key used when a standard representation of the key is needed outside the Java Virtual Machine, as when transmitting the key to some other party. The key is encoded according to a standard format (such as X.509 `SubjectPublicKeyInfo` or PKCS#8), and is returned using the `https://developer.android.com/reference/java/security/Key#getEncoded()` method. Note: The syntax of the ASN.1 type `SubjectPublicKeyInfo` is defined as follows:

  ```
  SubjectPublicKeyInfo ::= SEQUENCE {
    algorithm AlgorithmIdentifier,
    subjectPublicKey BIT STRING }

  AlgorithmIdentifier ::= SEQUENCE {
    algorithm OBJECT IDENTIFIER,
    parameters ANY DEFINED BY algorithm OPTIONAL }
  ```
  For more information, see [RFC 5280: Internet X.509 Public Key Infrastructure Certificate and CRL Profile](http://tools.ietf.org/html/rfc5280).
- A Format This is the name of the format of the encoded key. It is returned by the `https://developer.android.com/reference/java/security/Key#getFormat()` method.

Keys are generally obtained through key generators, certificates, key stores or other classes used to manage keys. Keys may also be obtained from key specifications (transparent representations of the underlying key material) through the use of a key factory (see `https://developer.android.com/reference/java/security/KeyFactory`).

A Key should use KeyRep as its serialized representation. Note that a serialized Key may contain sensitive information which should not be exposed in untrusted environments. See the [Security Appendix](https://docs.oracle.com/en/java/javase/17/docs/specs/serialization/security.html) of the Serialization Specification for more information.
**See also:**

- `https://developer.android.com/reference/java/security/PublicKey`
- `https://developer.android.com/reference/java/security/PrivateKey`
- `https://developer.android.com/reference/java/security/KeyPair`
- `https://developer.android.com/reference/java/security/KeyPairGenerator`
- `https://developer.android.com/reference/java/security/KeyFactory`
- `https://developer.android.com/reference/java/security/KeyRep`
- `https://developer.android.com/reference/java/security/spec/KeySpec`
- `https://developer.android.com/reference/java/security/Identity`
- `https://developer.android.com/reference/java/security/Signer`

## Summary

| ### Constants ||
|---|---|
| `long` | `https://developer.android.com/reference/java/security/Key#serialVersionUID` *This constant was deprecated in API level 34. A `serialVersionUID` field in an interface is ineffectual. Do not use; no replacement.* |

| ### Public methods ||
|---|---|
| ` abstract https://developer.android.com/reference/java/lang/String` | ` https://developer.android.com/reference/java/security/Key#getAlgorithm()() ` Returns the standard algorithm name for this key. |
| ` abstract byte[]` | ` https://developer.android.com/reference/java/security/Key#getEncoded()() ` Returns the key in its primary encoding format, or null if this key does not support encoding. |
| ` abstract https://developer.android.com/reference/java/lang/String` | ` https://developer.android.com/reference/java/security/Key#getFormat()() ` Returns the name of the primary encoding format of this key, or null if this key does not support encoding. |

## Constants

### serialVersionUID

Added in [API level 1](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)   
Deprecated in [API level 34](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final long serialVersionUID
```

<br />

**This constant was deprecated in API level 34.**   

A `serialVersionUID` field in an interface is ineffectual. Do not use; no replacement.

The class fingerprint that is set to indicate serialization compatibility with a previous version of the class.

<br />

Constant Value: 6603384152749567654 (0x5ba3eee69414eea6)

## Public methods

### getAlgorithm

Added in [API level 1](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public abstract String getAlgorithm ()
```

Returns the standard algorithm name for this key. For example, "DSA" would indicate that this key is a DSA key. See the key related sections (KeyFactory, KeyGenerator, KeyPairGenerator, and SecretKeyFactory) in the [Java Security Standard Algorithm Names Specification](https://docs.oracle.com/en/java/javase/17/docs/specs/security/standard-names.html) for information about standard key algorithm names.

<br />

| Returns ||
|---|---|
| `https://developer.android.com/reference/java/lang/String` | the name of the algorithm associated with this key. <br /> |

### getEncoded

Added in [API level 1](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public abstract byte[] getEncoded ()
```

Returns the key in its primary encoding format, or null if this key does not support encoding.

<br />

| Returns ||
|---|---|
| `byte[]` | the encoded key, or null if the key does not support encoding. <br /> |

### getFormat

Added in [API level 1](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public abstract String getFormat ()
```

Returns the name of the primary encoding format of this key, or null if this key does not support encoding. The primary encoding format is named in terms of the appropriate ASN.1 data format, if an ASN.1 specification for this key exists. For example, the name of the ASN.1 data format for public keys is *SubjectPublicKeyInfo*, as defined by the X.509 standard; in this case, the returned format is `"X.509"`. Similarly, the name of the ASN.1 data format for private keys is *PrivateKeyInfo*, as defined by the PKCS #8 standard; in this case, the returned format is `"PKCS#8"`.

<br />

| Returns ||
|---|---|
| `https://developer.android.com/reference/java/lang/String` | the primary encoding format of the key. <br /> |