Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels) Summary: [Constants](https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#constants) \| [Inherited Methods](https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#inhmethods)

# CarrierConfigManager.ImsVoice

*** ** * ** ***

` public static final class CarrierConfigManager.ImsVoice `   
` extends https://developer.android.com/reference/java/lang/Object ` ` `

|---|---|
| [java.lang.Object](https://developer.android.com/reference/java/lang/Object) ||
| ↳ | android.telephony.CarrierConfigManager.ImsVoice |

<br />

*** ** * ** ***

IMS Voice configs. This groups the configs required for IMS Voice - VoNR/VoLTE

Reference: IR.92

## Summary

| ### Constants ||
|---|---|
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#ALERTING_SRVCC_SUPPORT` SRVCC access transfer for calls in alerting phase as per 3GPP 24.237 and IR.64 Section 4.4. |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#BANDWIDTH_EFFICIENT` AMR NB/WB Payload format is bandwidth-efficient. |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#BASIC_SRVCC_SUPPORT` Indicates support for basic SRVCC, typically 1 active call as detailed in IR.92 Section A.3. |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#CONFERENCE_SUBSCRIBE_TYPE_IN_DIALOG` The SIP SUBSCRIBE to conference state events is sent in the SIP INVITE dialog between the UE and the conference server. |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#CONFERENCE_SUBSCRIBE_TYPE_OUT_OF_DIALOG` The SIP SUBSCRIBE to conference state events is sent out of the SIP INVITE dialog between the UE and the conference server. |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_ENCODED_BW_TYPE_FB` EVS encoded Bandwidth is Full Band (FB). |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_ENCODED_BW_TYPE_NB` EVS encoded Bandwidth is Narrow Band (NB). |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_ENCODED_BW_TYPE_NB_WB` EVS encoded Bandwidth is in the range NB,WB. |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_ENCODED_BW_TYPE_NB_WB_SWB` EVS encoded Bandwidth is in the range NB,WB,SWB. |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_ENCODED_BW_TYPE_NB_WB_SWB_FB` EVS encoded Bandwidth is in the range NB,WB,SWB,FB. |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_ENCODED_BW_TYPE_SWB` EVS encoded Bandwidth is Super WideBand (SWB). |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_ENCODED_BW_TYPE_WB` EVS encoded Bandwidth is Wide Band (WB). |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_ENCODED_BW_TYPE_WB_SWB` EVS encoded Bandwidth is in the range WB,SWB. |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_ENCODED_BW_TYPE_WB_SWB_FB` EVS encoded Bandwidth is in the range WB,SWB,FB. |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_OPERATIONAL_MODE_AMRWB_IO` Indicates the EVS AMR-WB IO mode. |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_OPERATIONAL_MODE_PRIMARY` Indicates the EVS primary mode. |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_PRIMARY_MODE_BITRATE_128_0_KBPS` EVS primary mode with bitrate 128.0 kbps |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_PRIMARY_MODE_BITRATE_13_2_KBPS` EVS primary mode with bitrate 13.2 kbps |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_PRIMARY_MODE_BITRATE_16_4_KBPS` EVS primary mode with bitrate 16.4 kbps |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_PRIMARY_MODE_BITRATE_24_4_KBPS` EVS primary mode with bitrate 24.4 kbps |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_PRIMARY_MODE_BITRATE_32_0_KBPS` EVS primary mode with bitrate 32.0 kbps |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_PRIMARY_MODE_BITRATE_48_0_KBPS` EVS primary mode with bitrate 48.0 kbps |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_PRIMARY_MODE_BITRATE_5_9_KBPS` EVS primary mode with bitrate 5.9 kbps |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_PRIMARY_MODE_BITRATE_64_0_KBPS` EVS primary mode with bitrate 64.0 kbps |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_PRIMARY_MODE_BITRATE_7_2_KBPS` EVS primary mode with bitrate 7.2 kbps |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_PRIMARY_MODE_BITRATE_8_0_KBPS` EVS primary mode with bitrate 8.0 kbps |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_PRIMARY_MODE_BITRATE_96_0_KBPS` EVS primary mode with bitrate 96.0 kbps |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_PRIMARY_MODE_BITRATE_9_6_KBPS` EVS primary mode with bitrate 9.6 kbps |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AMRNB_PAYLOAD_DESCRIPTION_BUNDLE` Specifies the codec attributes of different payload types in the AMR NarrowBand (AMR-NB) codec. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AMRNB_PAYLOAD_TYPE_INT_ARRAY` A list of integers representing the different payload types in AMR-NB codec in priority order from highest to lowest. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AMRWB_PAYLOAD_DESCRIPTION_BUNDLE` Specifies the codec attributes of different payload types in the AMR WideBand (AMR-WB) codec. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AMRWB_PAYLOAD_TYPE_INT_ARRAY` A list of integers representing the different payload types in AMR-WB codec in priority order from highest to lowest. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AMR_CODEC_ATTRIBUTE_MODESET_INT_ARRAY` Restricts the active mode set to a subset of all modes in the codec. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AMR_CODEC_ATTRIBUTE_PAYLOAD_FORMAT_INT` Specifies the payload format of the AMR-NB/AMR-WB codec. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AUDIO_AS_BANDWIDTH_KBPS_INT` Specifies the AS (Application Specific) SDP modifier for audio media. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AUDIO_CODEC_CAPABILITY_PAYLOAD_TYPES_BUNDLE` Specifies the Audio Codec capability. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AUDIO_INACTIVITY_CALL_END_REASONS_INT_ARRAY` List of various reasons of media inactivity for which voice/emergency call will end. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AUDIO_RR_BANDWIDTH_BPS_INT` Specifies the RR SDP modifier for audio media. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AUDIO_RS_BANDWIDTH_BPS_INT` Specifies the RS SDP modifier for audio media. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AUDIO_RTCP_INACTIVITY_TIMER_MILLIS_INT` Specifies the timeout value for RTCP inactivity for audio media. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AUDIO_RTP_INACTIVITY_TIMER_MILLIS_INT` Specifies the timeout value for RTP inactivity for audio media. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_CARRIER_VOLTE_ROAMING_AVAILABLE_BOOL` Flag specifying whether VoLTE should be available when on roaming network. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_CODEC_ATTRIBUTE_MODE_CHANGE_CAPABILITY_INT` Specifies if the client is capable to transmit with a restricted mode change period. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_CODEC_ATTRIBUTE_MODE_CHANGE_NEIGHBOR_INT` Specifies the allowed mode changes for the sender in the active mode set. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_CODEC_ATTRIBUTE_MODE_CHANGE_PERIOD_INT` Specifies the number of frame-blocks. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_CONFERENCE_FACTORY_URI_STRING` Used to specify the conference factory URI. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_CONFERENCE_SUBSCRIBE_TYPE_INT` This is used to specify whether the SIP SUBSCRIBE to conference state events, is sent in or out of the SIP INVITE dialog between the UE and the conference server. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_DEDICATED_BEARER_WAIT_TIMER_MILLIS_INT` Specifies the dedicated bearer wait time during call establishment. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_DTMFNB_PAYLOAD_TYPE_INT_ARRAY` A list of integers representing the different payload types in DTMF NB codec in priority order from highest to lowest. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_DTMFWB_PAYLOAD_TYPE_INT_ARRAY` A list of integers representing the different payload types in DTMF WB codec in priority order from highest to lowest. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_EVS_CODEC_ATTRIBUTE_BANDWIDTH_INT` Specifies the EVS codec encoding bandwidth options. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_EVS_CODEC_ATTRIBUTE_BITRATE_INT_ARRAY` Specifies the range of source codec bit-rate for EVS Primary mode in the session. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_EVS_CODEC_ATTRIBUTE_CHANNELS_INT` Specifies the number of audio channels. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_EVS_CODEC_ATTRIBUTE_CH_AW_RECV_INT` Specifies the Channel aware mode (ch-aw-recv) for the receive direction. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_EVS_CODEC_ATTRIBUTE_CMR_INT` Indicates whether the Codec Mode Request (CMR) is supported for the session. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_EVS_CODEC_ATTRIBUTE_DTX_BOOL` Specifies whether DTX (Discontinuous transmission) is enabled or not. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_EVS_CODEC_ATTRIBUTE_DTX_RECV_BOOL` This is used if further restriction is required on DTX in the receive direction. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_EVS_CODEC_ATTRIBUTE_HF_ONLY_INT` Specifies whether to limit the session to header-full format. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_EVS_CODEC_ATTRIBUTE_MODE_SWITCH_INT` Specifies if the EVS mode used is EVS primary mode or EVS AMR-WB IO mode. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_EVS_PAYLOAD_DESCRIPTION_BUNDLE` Specifies the codec attributes of different payload types in the EVS codec. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_EVS_PAYLOAD_TYPE_INT_ARRAY` A list of integers representing the different payload types in EVS codec in priority order from highest to lowest. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_INCLUDE_CALLER_ID_SERVICE_CODES_IN_SIP_INVITE_BOOL` Flag specifying whether to send vertical caller id service codes (\*67 and \*82) in the dialed string in the SIP:INVITE. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_MINIMUM_SESSION_EXPIRES_TIMER_SEC_INT` Indicates the minimum value for the session interval in seconds. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_MO_CALL_REQUEST_TIMEOUT_MILLIS_INT` Specifies the timer value for INVITE to the first 1xx response (including 100 trying). |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_MULTIENDPOINT_SUPPORTED_BOOL` Flag indicating whether Multi-end point setting is enabled or not. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_OIP_SOURCE_FROM_HEADER_BOOL` Flag specifying whether the 'From' header field is used for determination of the originating party identity in Originating Identification Presentation(OIP) service. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_PRACK_SUPPORTED_FOR_18X_BOOL` Flag indicating whether PRACK must be enabled for all 18x messages. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_PREFIX` Prefix of all imsvoice.KEY_\* constants. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_RINGBACK_TIMER_MILLIS_INT` Specifies the ringback timer for Mobile originated calls. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_RINGING_TIMER_MILLIS_INT` Specifies the ringing timer for Mobile terminated calls. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_SESSION_EXPIRES_TIMER_SEC_INT` Session-expires header field expressed in seconds as per RFC 4028 Section 3. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_SESSION_PRIVACY_TYPE_INT` Specify the session privacy type. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_SESSION_REFRESHER_TYPE_INT` Session Refresher entity as per RFC 4028 and IR.92 Section 2.2.8. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_SESSION_REFRESH_METHOD_INT` This is used to specify the method used for session refresh. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_SESSION_TIMER_SUPPORTED_BOOL` Flag indicating whether Supported header field with the option tag 'timer' is enabled or not. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_SRVCC_TYPE_INT_ARRAY` List of different SRVCC types supported as defined in 3GPP 24.237. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_VOICE_ON_DEFAULT_BEARER_SUPPORTED_BOOL` Flag specifying whether voice is allowed on default bearer. |
| `https://developer.android.com/reference/java/lang/String` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_VOICE_QOS_PRECONDITION_SUPPORTED_BOOL` Flag specifying whether QoS preconditions are supported during call setup. |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#MIDCALL_SRVCC_SUPPORT` SRVCC access transfer for calls in mid-call phase as per 3GPP 24.237. |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#OCTET_ALIGNED` AMR NB/WB Payload format is octet-aligned. |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#PREALERTING_SRVCC_SUPPORT` SRVCC access transfer for calls in pre-alerting phase as per 3GPP 24.237. |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#SESSION_PRIVACY_TYPE_HEADER` Session privacy type is HEADER as per RFC 3323 Section 4.2. |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#SESSION_PRIVACY_TYPE_ID` Session privacy type is ID as per RFC 3325 Section 9.3. |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#SESSION_PRIVACY_TYPE_NONE` Session privacy type is NONE as per RFC 3323 Section 4.2. |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#SESSION_REFRESHER_TYPE_UAC` Session Refresher entity is User Agent Client (UAC). |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#SESSION_REFRESHER_TYPE_UAS` Session Refresher entity is User Agent Server (UAS). |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#SESSION_REFRESHER_TYPE_UNKNOWN` Session Refresher entity is unknown. |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#SESSION_REFRESH_METHOD_INVITE` SIP INVITE is used for Session Refresh |
| `int` | `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#SESSION_REFRESH_METHOD_UPDATE_PREFERRED` Both SIP INVITE and UPDATE are used for session refresh. |

### Inherited methods

From class ` https://developer.android.com/reference/java/lang/Object ` ` https://developer.android.com/reference/java/lang/Object` ` https://developer.android.com/reference/java/lang/Object#clone()() `

Creates and returns a copy of this object.
` boolean` ` https://developer.android.com/reference/java/lang/Object#equals(java.lang.Object)(https://developer.android.com/reference/java/lang/Object obj) `

Indicates whether some other object is "equal to" this one.
` void` ` https://developer.android.com/reference/java/lang/Object#finalize()() `

Called by the garbage collector on an object when garbage collection determines that there are no more references to the object.
` final https://developer.android.com/reference/java/lang/Class<?>` ` https://developer.android.com/reference/java/lang/Object#getClass()() `

Returns the runtime class of this `Object`.
` int` ` https://developer.android.com/reference/java/lang/Object#hashCode()() `

Returns a hash code value for the object.
` final void` ` https://developer.android.com/reference/java/lang/Object#notify()() `

Wakes up a single thread that is waiting on this object's monitor.
` final void` ` https://developer.android.com/reference/java/lang/Object#notifyAll()() `

Wakes up all threads that are waiting on this object's monitor.
` https://developer.android.com/reference/java/lang/String` ` https://developer.android.com/reference/java/lang/Object#toString()() `

Returns a string representation of the object.
` final void` ` https://developer.android.com/reference/java/lang/Object#wait(long,%20int)(long timeoutMillis, int nanos) `

Causes the current thread to wait until it is awakened, typically by being *notified* or *interrupted*, or until a certain amount of real time has elapsed.
` final void` ` https://developer.android.com/reference/java/lang/Object#wait(long)(long timeoutMillis) `

Causes the current thread to wait until it is awakened, typically by being *notified* or *interrupted*, or until a certain amount of real time has elapsed.
` final void` ` https://developer.android.com/reference/java/lang/Object#wait()() `

Causes the current thread to wait until it is awakened, typically by being *notified* or *interrupted*.

## Constants

### ALERTING_SRVCC_SUPPORT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int ALERTING_SRVCC_SUPPORT
```

SRVCC access transfer for calls in alerting phase as per 3GPP 24.237 and IR.64 Section 4.4. Media feature tag used: g.3gpp.srvcc-alerting.

<br />

Constant Value: 1 (0x00000001)

### BANDWIDTH_EFFICIENT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int BANDWIDTH_EFFICIENT
```

AMR NB/WB Payload format is bandwidth-efficient.

<br />

Constant Value: 0 (0x00000000)

### BASIC_SRVCC_SUPPORT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int BASIC_SRVCC_SUPPORT
```

Indicates support for basic SRVCC, typically 1 active call as detailed in IR.92 Section A.3.

<br />

Constant Value: 0 (0x00000000)

### CONFERENCE_SUBSCRIBE_TYPE_IN_DIALOG

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int CONFERENCE_SUBSCRIBE_TYPE_IN_DIALOG
```

The SIP SUBSCRIBE to conference state events is sent in the SIP INVITE dialog between the UE and the conference server.

Reference: IR.92 Section 2.3.3.

<br />

Constant Value: 0 (0x00000000)

### CONFERENCE_SUBSCRIBE_TYPE_OUT_OF_DIALOG

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int CONFERENCE_SUBSCRIBE_TYPE_OUT_OF_DIALOG
```

The SIP SUBSCRIBE to conference state events is sent out of the SIP INVITE dialog between the UE and the conference server.

Reference: IR.92 Section 2.3.3.

<br />

Constant Value: 1 (0x00000001)

### EVS_ENCODED_BW_TYPE_FB

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EVS_ENCODED_BW_TYPE_FB
```

EVS encoded Bandwidth is Full Band (FB). Reference: 3GPP 26.441 Table 1.

<br />

Constant Value: 3 (0x00000003)

### EVS_ENCODED_BW_TYPE_NB

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EVS_ENCODED_BW_TYPE_NB
```

EVS encoded Bandwidth is Narrow Band (NB). Reference: 3GPP 26.441 Table 1.

<br />

Constant Value: 0 (0x00000000)

### EVS_ENCODED_BW_TYPE_NB_WB

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EVS_ENCODED_BW_TYPE_NB_WB
```

EVS encoded Bandwidth is in the range NB,WB. Reference: 3GPP 26.441 Table 1.

<br />

Constant Value: 4 (0x00000004)

### EVS_ENCODED_BW_TYPE_NB_WB_SWB

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EVS_ENCODED_BW_TYPE_NB_WB_SWB
```

EVS encoded Bandwidth is in the range NB,WB,SWB. Reference: 3GPP 26.441 Table 1.

<br />

Constant Value: 5 (0x00000005)

### EVS_ENCODED_BW_TYPE_NB_WB_SWB_FB

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EVS_ENCODED_BW_TYPE_NB_WB_SWB_FB
```

EVS encoded Bandwidth is in the range NB,WB,SWB,FB. Reference: 3GPP 26.441 Table 1.

<br />

Constant Value: 6 (0x00000006)

### EVS_ENCODED_BW_TYPE_SWB

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EVS_ENCODED_BW_TYPE_SWB
```

EVS encoded Bandwidth is Super WideBand (SWB). Reference: 3GPP 26.441 Table 1.

<br />

Constant Value: 2 (0x00000002)

### EVS_ENCODED_BW_TYPE_WB

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EVS_ENCODED_BW_TYPE_WB
```

EVS encoded Bandwidth is Wide Band (WB). Reference: 3GPP 26.441 Table 1.

<br />

Constant Value: 1 (0x00000001)

### EVS_ENCODED_BW_TYPE_WB_SWB

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EVS_ENCODED_BW_TYPE_WB_SWB
```

EVS encoded Bandwidth is in the range WB,SWB. Reference: 3GPP 26.441 Table 1.

<br />

Constant Value: 7 (0x00000007)

### EVS_ENCODED_BW_TYPE_WB_SWB_FB

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EVS_ENCODED_BW_TYPE_WB_SWB_FB
```

EVS encoded Bandwidth is in the range WB,SWB,FB. Reference: 3GPP 26.441 Table 1.

<br />

Constant Value: 8 (0x00000008)

### EVS_OPERATIONAL_MODE_AMRWB_IO

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EVS_OPERATIONAL_MODE_AMRWB_IO
```

Indicates the EVS AMR-WB IO mode. 3GPP 26.445 Section 3.1

<br />

Constant Value: 1 (0x00000001)

### EVS_OPERATIONAL_MODE_PRIMARY

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EVS_OPERATIONAL_MODE_PRIMARY
```

Indicates the EVS primary mode. 3GPP 26.445 Section 3.1

<br />

Constant Value: 0 (0x00000000)

### EVS_PRIMARY_MODE_BITRATE_128_0_KBPS

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EVS_PRIMARY_MODE_BITRATE_128_0_KBPS
```

EVS primary mode with bitrate 128.0 kbps

<br />

Constant Value: 11 (0x0000000b)

### EVS_PRIMARY_MODE_BITRATE_13_2_KBPS

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EVS_PRIMARY_MODE_BITRATE_13_2_KBPS
```

EVS primary mode with bitrate 13.2 kbps

<br />

Constant Value: 4 (0x00000004)

### EVS_PRIMARY_MODE_BITRATE_16_4_KBPS

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EVS_PRIMARY_MODE_BITRATE_16_4_KBPS
```

EVS primary mode with bitrate 16.4 kbps

<br />

Constant Value: 5 (0x00000005)

### EVS_PRIMARY_MODE_BITRATE_24_4_KBPS

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EVS_PRIMARY_MODE_BITRATE_24_4_KBPS
```

EVS primary mode with bitrate 24.4 kbps

<br />

Constant Value: 6 (0x00000006)

### EVS_PRIMARY_MODE_BITRATE_32_0_KBPS

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EVS_PRIMARY_MODE_BITRATE_32_0_KBPS
```

EVS primary mode with bitrate 32.0 kbps

<br />

Constant Value: 7 (0x00000007)

### EVS_PRIMARY_MODE_BITRATE_48_0_KBPS

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EVS_PRIMARY_MODE_BITRATE_48_0_KBPS
```

EVS primary mode with bitrate 48.0 kbps

<br />

Constant Value: 8 (0x00000008)

### EVS_PRIMARY_MODE_BITRATE_5_9_KBPS

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EVS_PRIMARY_MODE_BITRATE_5_9_KBPS
```

EVS primary mode with bitrate 5.9 kbps

<br />

Constant Value: 0 (0x00000000)

### EVS_PRIMARY_MODE_BITRATE_64_0_KBPS

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EVS_PRIMARY_MODE_BITRATE_64_0_KBPS
```

EVS primary mode with bitrate 64.0 kbps

<br />

Constant Value: 9 (0x00000009)

### EVS_PRIMARY_MODE_BITRATE_7_2_KBPS

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EVS_PRIMARY_MODE_BITRATE_7_2_KBPS
```

EVS primary mode with bitrate 7.2 kbps

<br />

Constant Value: 1 (0x00000001)

### EVS_PRIMARY_MODE_BITRATE_8_0_KBPS

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EVS_PRIMARY_MODE_BITRATE_8_0_KBPS
```

EVS primary mode with bitrate 8.0 kbps

<br />

Constant Value: 2 (0x00000002)

### EVS_PRIMARY_MODE_BITRATE_96_0_KBPS

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EVS_PRIMARY_MODE_BITRATE_96_0_KBPS
```

EVS primary mode with bitrate 96.0 kbps

<br />

Constant Value: 10 (0x0000000a)

### EVS_PRIMARY_MODE_BITRATE_9_6_KBPS

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EVS_PRIMARY_MODE_BITRATE_9_6_KBPS
```

EVS primary mode with bitrate 9.6 kbps

<br />

Constant Value: 3 (0x00000003)

### KEY_AMRNB_PAYLOAD_DESCRIPTION_BUNDLE

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_AMRNB_PAYLOAD_DESCRIPTION_BUNDLE
```

Specifies the codec attributes of different payload types in the AMR NarrowBand (AMR-NB) codec.

The keys in this bundle are payload types specified in `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AMRNB_PAYLOAD_TYPE_INT_ARRAY`.

Codec attributes allowed as part of AMR-NB codec bundle are,

- `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AMR_CODEC_ATTRIBUTE_PAYLOAD_FORMAT_INT`
- `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AMR_CODEC_ATTRIBUTE_MODESET_INT_ARRAY`

If this bundle is not configured and AMRNB payload type is added in `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AMRNB_PAYLOAD_TYPE_INT_ARRAY`, then default values as in the individual codec attribute to be used for that payload type.

<br />

Constant Value: "imsvoice.amrnb_payload_description_bundle"

### KEY_AMRNB_PAYLOAD_TYPE_INT_ARRAY

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_AMRNB_PAYLOAD_TYPE_INT_ARRAY
```

A list of integers representing the different payload types in AMR-NB codec in priority order from highest to lowest.

Payload type is an integer in dynamic payload type range 96-127 as per RFC RFC 3551 Section 6.

<br />

Constant Value: "imsvoice.amrnb_payload_type_int_array"

### KEY_AMRWB_PAYLOAD_DESCRIPTION_BUNDLE

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_AMRWB_PAYLOAD_DESCRIPTION_BUNDLE
```

Specifies the codec attributes of different payload types in the AMR WideBand (AMR-WB) codec.

The keys in this bundle are payload types specified in `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AMRWB_PAYLOAD_TYPE_INT_ARRAY`.

Codec attributes allowed as part of AMR-NB codec bundle are,

- `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AMR_CODEC_ATTRIBUTE_PAYLOAD_FORMAT_INT`
- `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AMR_CODEC_ATTRIBUTE_MODESET_INT_ARRAY`

If this bundle is not configured and AMRWB payload type is added in `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AMRWB_PAYLOAD_TYPE_INT_ARRAY`, then default values as in the individual codec attribute to be used for that payload type.

<br />

Constant Value: "imsvoice.amrwb_payload_description_bundle"

### KEY_AMRWB_PAYLOAD_TYPE_INT_ARRAY

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_AMRWB_PAYLOAD_TYPE_INT_ARRAY
```

A list of integers representing the different payload types in AMR-WB codec in priority order from highest to lowest.

Payload type is an integer in dynamic payload type range 96-127 as per RFC RFC 3551 Section 6.

<br />

Constant Value: "imsvoice.amrwb_payload_type_int_array"

### KEY_AMR_CODEC_ATTRIBUTE_MODESET_INT_ARRAY

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_AMR_CODEC_ATTRIBUTE_MODESET_INT_ARRAY
```

Restricts the active mode set to a subset of all modes in the codec.

This attribute is optional. If value is set, then session mode set is restricted to the modes specified in this list. If this value is not specified, then all available modes in the codec are allowed. This attribute is applicable for AMR-WB, AMR-NB, and EVS codec (operating in AMR-WB IO Mode).

Possible values are subset of, \[0,1,2,3,4,5,6,7,8\] - AMRWB with the modes representing nine speech codec modes with bit rates of 6.6, 8.85, 12.65, 14.25, 15.85, 18.25, 19.85, 23.05, 23.85 kbps. \[0,1,2,3,4,5,6,7\] - AMRNB with the modes representing eight speech codec modes with bit rates of 4.75, 5.15, 5.90, 6.70, 7.40, 7.95, 10.2, 12.2 kbps.

If value is not specified, then it means device supports all modes in the codec but not included in SDP.

Reference: RFC 4867 Section 8.1, 3GPP 26.445 A.3.1

<br />

Constant Value: "imsvoice.amr_codec_attribute_modeset_int_array"

### KEY_AMR_CODEC_ATTRIBUTE_PAYLOAD_FORMAT_INT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_AMR_CODEC_ATTRIBUTE_PAYLOAD_FORMAT_INT
```

Specifies the payload format of the AMR-NB/AMR-WB codec.

Possible values are, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#BANDWIDTH_EFFICIENT`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#OCTET_ALIGNED`

If value is not specified, payload format is `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#BANDWIDTH_EFFICIENT`.

Reference: RFC 4867 Section 8.1.

<br />

Constant Value: "imsvoice.amr_codec_attribute_payload_format_int"

### KEY_AUDIO_AS_BANDWIDTH_KBPS_INT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_AUDIO_AS_BANDWIDTH_KBPS_INT
```

Specifies the AS (Application Specific) SDP modifier for audio media.

This value is expressed in kilobits per second. Reference: RFC 3556 Section 2.

<br />

Constant Value: "imsvoice.audio_as_bandwidth_kbps_int"

### KEY_AUDIO_CODEC_CAPABILITY_PAYLOAD_TYPES_BUNDLE

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_AUDIO_CODEC_CAPABILITY_PAYLOAD_TYPES_BUNDLE
```

Specifies the Audio Codec capability. This contains a list of payload types representing different audio codec instances.

The priority of the codecs is EVS, AMRWB, AMRNB, DTMF WB, DTMF NB from highest to lowest. In each individual codec, the priority is determined by the order of the payload types from highest to lowest.

Possible keys in this bundle are,

- `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_EVS_PAYLOAD_TYPE_INT_ARRAY`
- `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AMRWB_PAYLOAD_TYPE_INT_ARRAY`
- `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AMRNB_PAYLOAD_TYPE_INT_ARRAY`
- `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_DTMFWB_PAYLOAD_TYPE_INT_ARRAY`
- `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_DTMFNB_PAYLOAD_TYPE_INT_ARRAY`

To specify payload descriptions for each of the audio payload types, see

- `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_EVS_PAYLOAD_DESCRIPTION_BUNDLE`
- `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AMRNB_PAYLOAD_DESCRIPTION_BUNDLE`
- `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AMRWB_PAYLOAD_DESCRIPTION_BUNDLE`

<br />

<br />

Constant Value: "imsvoice.audio_codec_capability_payload_types_bundle"

### KEY_AUDIO_INACTIVITY_CALL_END_REASONS_INT_ARRAY

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_AUDIO_INACTIVITY_CALL_END_REASONS_INT_ARRAY
```

List of various reasons of media inactivity for which voice/emergency call will end.

Possible values are, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.Ims#RTCP_INACTIVITY_ON_HOLD`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.Ims#RTCP_INACTIVITY_ON_CONNECTED`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.Ims#RTP_INACTIVITY_ON_CONNECTED` `https://developer.android.com/reference/android/telephony/CarrierConfigManager.Ims#E911_RTCP_INACTIVITY_ON_CONNECTED`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.Ims#E911_RTP_INACTIVITY_ON_CONNECTED`

<br />

Constant Value: "imsvoice.audio_inactivity_call_end_reasons_int_array"

### KEY_AUDIO_RR_BANDWIDTH_BPS_INT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_AUDIO_RR_BANDWIDTH_BPS_INT
```

Specifies the RR SDP modifier for audio media. This indicates the RTCP bandwidth allocated to receivers for audio media.

This value is expressed in bits per second. Reference: RFC 3556 Section 2.

<br />

Constant Value: "imsvoice.audio_rr_bandwidth_bps_int"

### KEY_AUDIO_RS_BANDWIDTH_BPS_INT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_AUDIO_RS_BANDWIDTH_BPS_INT
```

Specifies the RS SDP modifier for audio media. This indicates the RTCP bandwidth allocated to active data senders for audio media.

This value is expressed in bits per second. Reference: RFC 3556 Section 2.

<br />

Constant Value: "imsvoice.audio_rs_bandwidth_bps_int"

### KEY_AUDIO_RTCP_INACTIVITY_TIMER_MILLIS_INT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_AUDIO_RTCP_INACTIVITY_TIMER_MILLIS_INT
```

Specifies the timeout value for RTCP inactivity for audio media.

On timer expiry, call will end. See `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AUDIO_INACTIVITY_CALL_END_REASONS_INT_ARRAY` for more details.

Value of 0 means this timer is not enabled.

<br />

Constant Value: "imsvoice.audio_rtcp_inactivity_timer_millis_int"

### KEY_AUDIO_RTP_INACTIVITY_TIMER_MILLIS_INT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_AUDIO_RTP_INACTIVITY_TIMER_MILLIS_INT
```

Specifies the timeout value for RTP inactivity for audio media.

On timer expiry, call will end. See `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_AUDIO_INACTIVITY_CALL_END_REASONS_INT_ARRAY` for more details.

Value of 0 means this timer is not enabled.

<br />

Constant Value: "imsvoice.audio_rtp_inactivity_timer_millis_int"

### KEY_CARRIER_VOLTE_ROAMING_AVAILABLE_BOOL

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_CARRIER_VOLTE_ROAMING_AVAILABLE_BOOL
```

Flag specifying whether VoLTE should be available when on roaming network.

If `false`: hard disabled. If `true`: then depends on availability, etc.

<br />

Constant Value: "imsvoice.carrier_volte_roaming_available_bool"

### KEY_CODEC_ATTRIBUTE_MODE_CHANGE_CAPABILITY_INT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_CODEC_ATTRIBUTE_MODE_CHANGE_CAPABILITY_INT
```

Specifies if the client is capable to transmit with a restricted mode change period. This attribute is applicable for EVS codec in AMR-WB IO mode and AMR-WB.

Possible values are 1, 2. If this key is not present, then behavior as per value 1 is applicable and this parameter is not included in SDP.

Reference: RFC 4867 Section 8.1.

<br />

Constant Value: "imsvoice.codec_attribute_mode_change_capability_int"

### KEY_CODEC_ATTRIBUTE_MODE_CHANGE_NEIGHBOR_INT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_CODEC_ATTRIBUTE_MODE_CHANGE_NEIGHBOR_INT
```

Specifies the allowed mode changes for the sender in the active mode set. This attribute is applicable for EVS codec in AMR-WB IO mode and AMR-WB.

Possible values are 0, 1. If value is 1, then the sender should only perform mode changes to the neighboring modes in the active codec mode set. If value is 0, then mode changes between any two modes in the active codec mode set is allowed. If the key is not present, behavior as per value 0 is applicable and this parameter is not included in SDP.

Reference: RFC 4867 Section 8.1.

<br />

Constant Value: "imsvoice.codec_attribute_mode_change_neighbor_int"

### KEY_CODEC_ATTRIBUTE_MODE_CHANGE_PERIOD_INT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_CODEC_ATTRIBUTE_MODE_CHANGE_PERIOD_INT
```

Specifies the number of frame-blocks. This indicates the frame-block period at which codec mode changes are allowed for the sender. This attribute is applicable for EVS codec in AMR-WB IO mode and AMR-WB.

Possible values are 1, 2. If the key is not present, behavior as per value 1 is applicable and this parameter is not included in SDP.

Reference: RFC 4867 Section 8.1.

<br />

Constant Value: "imsvoice.codec_attribute_mode_change_period_int"

### KEY_CONFERENCE_FACTORY_URI_STRING

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_CONFERENCE_FACTORY_URI_STRING
```

Used to specify the conference factory URI.

If this is empty, then conference URI is generated from MCC/MNC as specified in clause 13.10 of 3GPP 23.003.

<br />

Constant Value: "imsvoice.conference_factory_uri_string"

### KEY_CONFERENCE_SUBSCRIBE_TYPE_INT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_CONFERENCE_SUBSCRIBE_TYPE_INT
```

This is used to specify whether the SIP SUBSCRIBE to conference state events, is sent in or out of the SIP INVITE dialog between the UE and the conference server.

Reference: IR.92 Section 2.3.3.

Possible values are, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#CONFERENCE_SUBSCRIBE_TYPE_IN_DIALOG`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#CONFERENCE_SUBSCRIBE_TYPE_OUT_OF_DIALOG` An empty array indicates SUBSCRIBE to conference event package is not required.

<br />

Constant Value: "imsvoice.conference_subscribe_type_int"

### KEY_DEDICATED_BEARER_WAIT_TIMER_MILLIS_INT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_DEDICATED_BEARER_WAIT_TIMER_MILLIS_INT
```

Specifies the dedicated bearer wait time during call establishment.

If dedicated bearer is not established within this time and if `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_VOICE_ON_DEFAULT_BEARER_SUPPORTED_BOOL` is false, then call setup would fail.

If dedicated bearer is not established within this time and if `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_VOICE_ON_DEFAULT_BEARER_SUPPORTED_BOOL` is true, then the media is allowed on default bearer.

<br />

Constant Value: "imsvoice.dedicated_bearer_wait_timer_millis_int"

### KEY_DTMFNB_PAYLOAD_TYPE_INT_ARRAY

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_DTMFNB_PAYLOAD_TYPE_INT_ARRAY
```

A list of integers representing the different payload types in DTMF NB codec in priority order from highest to lowest.

Payload type is an integer in dynamic payload type range 96-127 as per RFC RFC 3551 Section 6.

<br />

Constant Value: "imsvoice.dtmfnb_payload_type_int_array"

### KEY_DTMFWB_PAYLOAD_TYPE_INT_ARRAY

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_DTMFWB_PAYLOAD_TYPE_INT_ARRAY
```

A list of integers representing the different payload types in DTMF WB codec in priority order from highest to lowest.

Payload type is an integer in dynamic payload type range 96-127 as per RFC RFC 3551 Section 6.

<br />

Constant Value: "imsvoice.dtmfwb_payload_type_int_array"

### KEY_EVS_CODEC_ATTRIBUTE_BANDWIDTH_INT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_EVS_CODEC_ATTRIBUTE_BANDWIDTH_INT
```

Specifies the EVS codec encoding bandwidth options. Possible values are, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_ENCODED_BW_TYPE_NB`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_ENCODED_BW_TYPE_WB`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_ENCODED_BW_TYPE_SWB`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_ENCODED_BW_TYPE_FB`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_ENCODED_BW_TYPE_NB_WB`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_ENCODED_BW_TYPE_NB_WB_SWB`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_ENCODED_BW_TYPE_NB_WB_SWB_FB`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_ENCODED_BW_TYPE_WB_SWB`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_ENCODED_BW_TYPE_WB_SWB_FB` If this key is not specified, then the behavior is same as value `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_ENCODED_BW_TYPE_NB_WB_SWB`

Reference: 3GPP 26.441 Table 1.

<br />

Constant Value: "imsvoice.evs_codec_attribute_bandwidth_int"

### KEY_EVS_CODEC_ATTRIBUTE_BITRATE_INT_ARRAY

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_EVS_CODEC_ATTRIBUTE_BITRATE_INT_ARRAY
```

Specifies the range of source codec bit-rate for EVS Primary mode in the session. This is expressed in kilobits per second and applicable for both the send and the receive directions.

The range is specified as integer aray of size 2, represented as \[low, high\], where low \<= high

Possible values for low and high are, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_PRIMARY_MODE_BITRATE_5_9_KBPS`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_PRIMARY_MODE_BITRATE_7_2_KBPS`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_PRIMARY_MODE_BITRATE_8_0_KBPS`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_PRIMARY_MODE_BITRATE_9_6_KBPS`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_PRIMARY_MODE_BITRATE_13_2_KBPS`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_PRIMARY_MODE_BITRATE_16_4_KBPS`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_PRIMARY_MODE_BITRATE_24_4_KBPS`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_PRIMARY_MODE_BITRATE_32_0_KBPS`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_PRIMARY_MODE_BITRATE_48_0_KBPS`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_PRIMARY_MODE_BITRATE_64_0_KBPS`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_PRIMARY_MODE_BITRATE_96_0_KBPS`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_PRIMARY_MODE_BITRATE_128_0_KBPS` If this key is not specified, then the behavior is same as value `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_PRIMARY_MODE_BITRATE_24_4_KBPS`

Reference: 3GPP 26.445 Section A.3.1

<br />

Constant Value: "imsvoice.evs_codec_attribute_bitrate_int_array"

### KEY_EVS_CODEC_ATTRIBUTE_CHANNELS_INT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_EVS_CODEC_ATTRIBUTE_CHANNELS_INT
```

Specifies the number of audio channels. If this is not present, then default value of 1 will apply.

Reference: RFC 3551

<br />

Constant Value: "imsvoice.evs_codec_attribute_channels_int"

### KEY_EVS_CODEC_ATTRIBUTE_CH_AW_RECV_INT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_EVS_CODEC_ATTRIBUTE_CH_AW_RECV_INT
```

Specifies the Channel aware mode (ch-aw-recv) for the receive direction. This is applicable for EVS codec.

Permissible values are -1, 0, 2, 3, 5, and 7. If this key is not specified, then the behavior is same as value 0 (channel aware mode disabled).

If this key is configured, then device is expected to send this parameter in the SDP offer.

Reference: 3GPP TS 26.445 section 4.4.5, 3GPP 26.445 Section A.3.1

<br />

Constant Value: "imsvoice.evs_codec_attribute_ch_aw_recv_int"

### KEY_EVS_CODEC_ATTRIBUTE_CMR_INT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_EVS_CODEC_ATTRIBUTE_CMR_INT
```

Indicates whether the Codec Mode Request (CMR) is supported for the session. This attribute is applicable for EVS codec in Primary Mode only.

Possible values are -1, 0, 1. If this key is not present, then behavior as per value 0 is applicable.

Reference: 3GPP 26.445 Section A.3.1, 3GPP 26.114 Table 6.2a

<br />

Constant Value: "imsvoice.codec_attribute_cmr_int"

### KEY_EVS_CODEC_ATTRIBUTE_DTX_BOOL

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_EVS_CODEC_ATTRIBUTE_DTX_BOOL
```

Specifies whether DTX (Discontinuous transmission) is enabled or not. This applies to both directions in the session. This attribute is applicable for EVS codec and can be used in both EVS Primary mode and EVS AMR-WB IO mode.

If `true`: Indicates DTX is enabled. If `false`: Indicates DTX is disabled.

If this is not present, then default value of `true` will apply.

Reference: 3GPP TS 26.445 Section A.3.1.

<br />

Constant Value: "imsvoice.evs_codec_attribute_dtx_bool"

### KEY_EVS_CODEC_ATTRIBUTE_DTX_RECV_BOOL

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_EVS_CODEC_ATTRIBUTE_DTX_RECV_BOOL
```

This is used if further restriction is required on DTX in the receive direction. This attribute is applicable for EVS codec and can be used in both EVS Primary mode and EVS AMR-WB IO mode.

If this value is true or not present, then DTX setting is dependent on `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_EVS_CODEC_ATTRIBUTE_DTX_BOOL`.

If this is not present, then default value of `true` will apply.

Reference: 3GPP TS 26.445 Section A.3.1.

<br />

Constant Value: "imsvoice.evs_codec_attribute_dtx_recv_bool"

### KEY_EVS_CODEC_ATTRIBUTE_HF_ONLY_INT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_EVS_CODEC_ATTRIBUTE_HF_ONLY_INT
```

Specifies whether to limit the session to header-full format. This applies to both directions in the session. This attribute is applicable for EVS codec.

Permissible values are 0, 1 If hf-only is 1, only Header-Full format is used and hf-only is included in the SDP.

If hf-only is 0, both Compact and Header-Full formats are used and hf-only is included in the SDP.

If this key is not present, then both Compact and Header-Full formats are used and hf-only is not included in the SDP.

If this key is configured, then device is expected to send this parameter in the SDP offer if operator required it.

Reference: 3GPP 26.445 Section A.3.1.

<br />

Constant Value: "imsvoice.evs_codec_attribute_hf_only_int"

### KEY_EVS_CODEC_ATTRIBUTE_MODE_SWITCH_INT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_EVS_CODEC_ATTRIBUTE_MODE_SWITCH_INT
```

Specifies if the EVS mode used is EVS primary mode or EVS AMR-WB IO mode.

Possible values are, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_OPERATIONAL_MODE_PRIMARY`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_OPERATIONAL_MODE_AMRWB_IO`

If this is not present, then `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#EVS_OPERATIONAL_MODE_PRIMARY` is used.

Reference: 3GPP 26.445 Section 3.1.

<br />

Constant Value: "imsvoice.evs_codec_attribute_mode_switch_int"

### KEY_EVS_PAYLOAD_DESCRIPTION_BUNDLE

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_EVS_PAYLOAD_DESCRIPTION_BUNDLE
```

Specifies the codec attributes of different payload types in the EVS codec.

The keys in this bundle are payload types specified in `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_EVS_PAYLOAD_TYPE_INT_ARRAY`.

Codec attributes allowed as part of EVS codec are,

- `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_EVS_CODEC_ATTRIBUTE_BANDWIDTH_INT`
- `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_EVS_CODEC_ATTRIBUTE_BITRATE_INT_ARRAY`
- `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_EVS_CODEC_ATTRIBUTE_CH_AW_RECV_INT`
- `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_EVS_CODEC_ATTRIBUTE_HF_ONLY_INT`
- `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_EVS_CODEC_ATTRIBUTE_DTX_BOOL`
- `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_EVS_CODEC_ATTRIBUTE_DTX_RECV_BOOL`
- `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_EVS_CODEC_ATTRIBUTE_MODE_SWITCH_INT`
- `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_EVS_CODEC_ATTRIBUTE_CMR_INT`
- `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_EVS_CODEC_ATTRIBUTE_CHANNELS_INT`
- `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_CODEC_ATTRIBUTE_MODE_CHANGE_PERIOD_INT`
- `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_CODEC_ATTRIBUTE_MODE_CHANGE_CAPABILITY_INT`
- `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#KEY_CODEC_ATTRIBUTE_MODE_CHANGE_NEIGHBOR_INT`

<br />

<br />

Constant Value: "imsvoice.evs_payload_description_bundle"

### KEY_EVS_PAYLOAD_TYPE_INT_ARRAY

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_EVS_PAYLOAD_TYPE_INT_ARRAY
```

A list of integers representing the different payload types in EVS codec in priority order from highest to lowest.

Payload type is an integer in dynamic payload type range 96-127 as per RFC RFC 3551 Section 6.

<br />

Constant Value: "imsvoice.evs_payload_type_int_array"

### KEY_INCLUDE_CALLER_ID_SERVICE_CODES_IN_SIP_INVITE_BOOL

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_INCLUDE_CALLER_ID_SERVICE_CODES_IN_SIP_INVITE_BOOL
```

Flag specifying whether to send vertical caller id service codes (\*67 and \*82) in the dialed string in the SIP:INVITE.

If `true`, vertical caller id service codes \*67 and \*82 will be sent in the dialed string in the SIP:INVITE. If `false`, \*67 and \*82 will be removed.

<br />

Constant Value: "imsvoice.include_caller_id_service_codes_in_sip_invite_bool"

### KEY_MINIMUM_SESSION_EXPIRES_TIMER_SEC_INT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_MINIMUM_SESSION_EXPIRES_TIMER_SEC_INT
```

Indicates the minimum value for the session interval in seconds. Represented as min-SE header field as per RFC 4028 Section 3.

This establishes the lower bound for the session refresh interval.

<br />

Constant Value: "imsvoice.minimum_session_expires_timer_sec_int"

### KEY_MO_CALL_REQUEST_TIMEOUT_MILLIS_INT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_MO_CALL_REQUEST_TIMEOUT_MILLIS_INT
```

Specifies the timer value for INVITE to the first 1xx response (including 100 trying). If no response is received at timer expiry, call is redialed over CS.

Reference: 24.173 Table L.1

<br />

Constant Value: "imsvoice.mo_call_request_timeout_millis_int"

### KEY_MULTIENDPOINT_SUPPORTED_BOOL

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_MULTIENDPOINT_SUPPORTED_BOOL
```

Flag indicating whether Multi-end point setting is enabled or not.

<br />

Constant Value: "imsvoice.multiendpoint_supported_bool"

### KEY_OIP_SOURCE_FROM_HEADER_BOOL

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_OIP_SOURCE_FROM_HEADER_BOOL
```

Flag specifying whether the 'From' header field is used for determination of the originating party identity in Originating Identification Presentation(OIP) service.

If `true`: Indicates that the 'From' header field is used for determination of the originating party identity in OIP. `false` otherwise.

<br />

Constant Value: "imsvoice.oip_source_from_header_bool"

### KEY_PRACK_SUPPORTED_FOR_18X_BOOL

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_PRACK_SUPPORTED_FOR_18X_BOOL
```

Flag indicating whether PRACK must be enabled for all 18x messages.

If `false`, only 18x responses with SDP are sent reliably. If `true`, SIP 18x responses (other than SIP 183 response) are sent reliably.

<br />

Constant Value: "imsvoice.prack_supported_for_18x_bool"

### KEY_PREFIX

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_PREFIX
```

Prefix of all imsvoice.KEY_\* constants.

<br />

Constant Value: "imsvoice."

### KEY_RINGBACK_TIMER_MILLIS_INT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_RINGBACK_TIMER_MILLIS_INT
```

Specifies the ringback timer for Mobile originated calls.

Ringback timer starts when the device receives SIP 180 Ringing in response to its SIP INVITE. If Ringback timer expires, the device sends SIP CANCEL.

<br />

Constant Value: "imsvoice.ringback_timer_millis_int"

### KEY_RINGING_TIMER_MILLIS_INT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_RINGING_TIMER_MILLIS_INT
```

Specifies the ringing timer for Mobile terminated calls.

Ringing timer starts when the device sends SIP 180 Ringing in response to a received SIP INVITE. If Ringing timer expires, the device sends SIP 486 response.

<br />

Constant Value: "imsvoice.ringing_timer_millis_int"

### KEY_SESSION_EXPIRES_TIMER_SEC_INT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_SESSION_EXPIRES_TIMER_SEC_INT
```

Session-expires header field expressed in seconds as per RFC 4028 Section 3.

This establishes the upper bound for the session refresh interval.

<br />

Constant Value: "imsvoice.session_expires_timer_sec_int"

### KEY_SESSION_PRIVACY_TYPE_INT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_SESSION_PRIVACY_TYPE_INT
```

Specify the session privacy type.

Reference: RFC 3323 Section 4.2, RFC 3325 Section 9.3.

Possible values are, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#SESSION_PRIVACY_TYPE_HEADER`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#SESSION_PRIVACY_TYPE_NONE`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#SESSION_PRIVACY_TYPE_ID`

<br />

Constant Value: "imsvoice.session_privacy_type_int"

### KEY_SESSION_REFRESHER_TYPE_INT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_SESSION_REFRESHER_TYPE_INT
```

Session Refresher entity as per RFC 4028 and IR.92 Section 2.2.8.

This determines, a) whether to include the "refresher" parameter b) Type of refresher" parameter in the Session-Expires header field of the SIP INVITE request.

Possible values are, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#SESSION_REFRESHER_TYPE_UNKNOWN`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#SESSION_REFRESHER_TYPE_UAC`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#SESSION_REFRESHER_TYPE_UAS`

<br />

Constant Value: "imsvoice.session_refresher_type_int"

### KEY_SESSION_REFRESH_METHOD_INT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_SESSION_REFRESH_METHOD_INT
```

This is used to specify the method used for session refresh.

Possible values are, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#SESSION_REFRESH_METHOD_INVITE`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#SESSION_REFRESH_METHOD_UPDATE_PREFERRED`

<br />

Constant Value: "imsvoice.session_refresh_method_int"

### KEY_SESSION_TIMER_SUPPORTED_BOOL

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_SESSION_TIMER_SUPPORTED_BOOL
```

Flag indicating whether Supported header field with the option tag 'timer' is enabled or not.

If `true`, session timer support is available.`false` otherwise. Reference: RFC 4028 Section 3

<br />

Constant Value: "imsvoice.session_timer_supported_bool"

### KEY_SRVCC_TYPE_INT_ARRAY

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_SRVCC_TYPE_INT_ARRAY
```

List of different SRVCC types supported as defined in 3GPP 24.237.

Possible values are, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#BASIC_SRVCC_SUPPORT`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#ALERTING_SRVCC_SUPPORT`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#PREALERTING_SRVCC_SUPPORT`, `https://developer.android.com/reference/android/telephony/CarrierConfigManager.ImsVoice#MIDCALL_SRVCC_SUPPORT`

Reference: IR.64, 3GPP 24.237, 3GPP 23.216

<br />

Constant Value: "imsvoice.srvcc_type_int_array"

### KEY_VOICE_ON_DEFAULT_BEARER_SUPPORTED_BOOL

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_VOICE_ON_DEFAULT_BEARER_SUPPORTED_BOOL
```

Flag specifying whether voice is allowed on default bearer.

If `true`: voice packets can be sent on default bearer. `false` otherwise.

<br />

Constant Value: "imsvoice.voice_on_default_bearer_supported_bool"

### KEY_VOICE_QOS_PRECONDITION_SUPPORTED_BOOL

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final String KEY_VOICE_QOS_PRECONDITION_SUPPORTED_BOOL
```

Flag specifying whether QoS preconditions are supported during call setup.

If `true`: QoS Preconditions are supported during call setup and 'precondition' tag is included in the SIP INVITE header and precondition parameters are sent in SDP as required.

If `false`: QoS Preconditions are not supported during call setup.

Reference: 3GPP TS 24.229

<br />

Constant Value: "imsvoice.voice_qos_precondition_supported_bool"

### MIDCALL_SRVCC_SUPPORT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int MIDCALL_SRVCC_SUPPORT
```

SRVCC access transfer for calls in mid-call phase as per 3GPP 24.237. and IR.64 Section 4.4.

This means UE supports the MSC server assisted mid-call feature. Media feature tag used: g.3gpp.mid-call.

<br />

Constant Value: 3 (0x00000003)

### OCTET_ALIGNED

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int OCTET_ALIGNED
```

AMR NB/WB Payload format is octet-aligned.

<br />

Constant Value: 1 (0x00000001)

### PREALERTING_SRVCC_SUPPORT

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int PREALERTING_SRVCC_SUPPORT
```

SRVCC access transfer for calls in pre-alerting phase as per 3GPP 24.237. Media feature tag used: g.3gpp.ps2cs-srvcc-orig-pre-alerting.

<br />

Constant Value: 2 (0x00000002)

### SESSION_PRIVACY_TYPE_HEADER

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int SESSION_PRIVACY_TYPE_HEADER
```

Session privacy type is HEADER as per RFC 3323 Section 4.2.

<br />

Constant Value: 0 (0x00000000)

### SESSION_PRIVACY_TYPE_ID

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int SESSION_PRIVACY_TYPE_ID
```

Session privacy type is ID as per RFC 3325 Section 9.3.

<br />

Constant Value: 2 (0x00000002)

### SESSION_PRIVACY_TYPE_NONE

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int SESSION_PRIVACY_TYPE_NONE
```

Session privacy type is NONE as per RFC 3323 Section 4.2.

<br />

Constant Value: 1 (0x00000001)

### SESSION_REFRESHER_TYPE_UAC

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int SESSION_REFRESHER_TYPE_UAC
```

Session Refresher entity is User Agent Client (UAC).

Type of "refresher" parameter in the Session-Expires header field of the SIP INVITE request is UAC.

<br />

Constant Value: 1 (0x00000001)

### SESSION_REFRESHER_TYPE_UAS

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int SESSION_REFRESHER_TYPE_UAS
```

Session Refresher entity is User Agent Server (UAS).

Type of "refresher" parameter in the Session-Expires header field of the SIP INVITE request is UAS.

<br />

Constant Value: 2 (0x00000002)

### SESSION_REFRESHER_TYPE_UNKNOWN

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int SESSION_REFRESHER_TYPE_UNKNOWN
```

Session Refresher entity is unknown. This means UE does not include the "refresher" parameter in the Session-Expires header field of the SIP INVITE request.

<br />

Constant Value: 0 (0x00000000)

### SESSION_REFRESH_METHOD_INVITE

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int SESSION_REFRESH_METHOD_INVITE
```

SIP INVITE is used for Session Refresh

<br />

Constant Value: 0 (0x00000000)

### SESSION_REFRESH_METHOD_UPDATE_PREFERRED

Added in [API level 33](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int SESSION_REFRESH_METHOD_UPDATE_PREFERRED
```

Both SIP INVITE and UPDATE are used for session refresh.

SIP UPDATE will be used if UPDATE is in 'Allow' header. If UPDATE is not in 'Allow' header, then INVITE will be used.

<br />

Constant Value: 1 (0x00000001)