コンテンツに移動

よくアクセスするページ

最近アクセスしたページ

navigation
added in API level 21

android.service.voice

Classes

AlwaysOnHotwordDetector A class that lets a VoiceInteractionService implementation interact with always-on keyphrase detection APIs. 
AlwaysOnHotwordDetector.Callback Callbacks for always-on hotword detection. 
AlwaysOnHotwordDetector.EventPayload Additional payload for onDetected(AlwaysOnHotwordDetector.EventPayload)
VoiceInteractionService Top-level service of the current global voice interactor, which is providing support for hotwording, the back-end of a VoiceInteractor, etc. 
VoiceInteractionSession An active voice interaction session, providing a facility for the implementation to interact with the user in the voice interaction layer. 
VoiceInteractionSession.AbortVoiceRequest A request to report that the current user interaction can not be completed with voice, as per VoiceInteractor.AbortVoiceRequest
VoiceInteractionSession.CommandRequest A generic vendor-specific request, as per VoiceInteractor.CommandRequest
VoiceInteractionSession.CompleteVoiceRequest A request to simply inform the user that the voice operation has completed, as per VoiceInteractor.CompleteVoiceRequest
VoiceInteractionSession.ConfirmationRequest A request for confirmation from the user of an operation, as per VoiceInteractor.ConfirmationRequest
VoiceInteractionSession.Insets Information about where interesting parts of the input method UI appear. 
VoiceInteractionSession.PickOptionRequest A request for the user to pick from a set of option, as per VoiceInteractor.PickOptionRequest
VoiceInteractionSession.Request Base class representing a request from a voice-driver app to perform a particular voice operation with the user. 
VoiceInteractionSessionService An active voice interaction session, initiated by a VoiceInteractionService
このサイトでは、ユーザーが選択したサイトの言語と表示設定を保存する目的で Cookie を使用しています。

Android デベロッパー向けの最新情報やヒントを入手して、Google Play での成功を手に入れましょう。

* 必須

送信しました

WeChat で Google Developers をフォローする

このサイトをで表示しますか?

ページの表示言語としてを選択しましたが、このサイトの言語はに設定されています。

言語設定を変更してこのサイトをで表示しますか?言語設定を変更する場合は、各ページの下にある言語メニューを使用してください。

このクラスには、API レベル 以上が必要です。

API レベル が選択されているため、このドキュメントは非表示になっています。左のナビゲーションの上にあるセレクタを使って、ドキュメントの API レベルを変更できます。

アプリに必要な API レベルを指定する方法について、詳しくは異なるプラットフォーム バージョンのサポートをご覧ください。

Take a short survey?
Help us improve the Android developer experience. (April 2018 — Developer Survey)