Skip to content

Most visited

Recently visited

navigation

ProgramStore.BlendDstFunc | Android Developers

to top
Android APIs
public static final enum

ProgramStore.BlendDstFunc

extends Enum<E extends Enum<E>>
java.lang.Object
   ↳ java.lang.Enum<E extends java.lang.Enum<E>>
     ↳ android.renderscript.ProgramStore.BlendDstFunc

Class Overview

Specifies the functions used to combine incoming pixels with those already in the frame buffer. BlendDstFunc describes how the coefficient used to scale the pixels already in the framebuffer is computed during the blending operation

Summary

Enum Values
ProgramStore.BlendDstFunc  DST_ALPHA   
ProgramStore.BlendDstFunc  ONE   
ProgramStore.BlendDstFunc  ONE_MINUS_DST_ALPHA   
ProgramStore.BlendDstFunc  ONE_MINUS_SRC_ALPHA   
ProgramStore.BlendDstFunc  ONE_MINUS_SRC_COLOR   
ProgramStore.BlendDstFunc  SRC_ALPHA   
ProgramStore.BlendDstFunc  SRC_COLOR   
ProgramStore.BlendDstFunc  ZERO   
Public Methods
static ProgramStore.BlendDstFunc valueOf(String name)
final static BlendDstFunc[] values()
[Expand]
Inherited Methods
From class java.lang.Enum
From class java.lang.Object
From interface java.lang.Comparable

Enum Values

public static final ProgramStore.BlendDstFunc DST_ALPHA

public static final ProgramStore.BlendDstFunc ONE

public static final ProgramStore.BlendDstFunc ONE_MINUS_DST_ALPHA

public static final ProgramStore.BlendDstFunc ONE_MINUS_SRC_ALPHA

public static final ProgramStore.BlendDstFunc ONE_MINUS_SRC_COLOR

public static final ProgramStore.BlendDstFunc SRC_ALPHA

public static final ProgramStore.BlendDstFunc SRC_COLOR

public static final ProgramStore.BlendDstFunc ZERO

Public Methods

public static ProgramStore.BlendDstFunc valueOf (String name)

Added in API level 11

public static final BlendDstFunc[] values ()

Added in API level 11

This site uses cookies to store your preferences for site-specific language and display options.

Hooray!

This class requires API level or higher

This doc is hidden because your selected API level for the documentation is . You can change the documentation API level with the selector above the left navigation.

For more information about specifying the API level your app requires, read Supporting Different Platform Versions.

Take a one-minute survey?
Help us improve Android tools and documentation.