Added in [API level 31](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels) Summary: [Constants](https://developer.android.com/reference/android/net/eap/EapSessionConfig.EapMethodConfig#constants) \| [Methods](https://developer.android.com/reference/android/net/eap/EapSessionConfig.EapMethodConfig#pubmethods) \| [Inherited Methods](https://developer.android.com/reference/android/net/eap/EapSessionConfig.EapMethodConfig#inhmethods)

# EapSessionConfig.EapMethodConfig

*** ** * ** ***

` public static abstract class EapSessionConfig.EapMethodConfig `   
` extends https://developer.android.com/reference/java/lang/Object ` ` `

|---|---|
| [java.lang.Object](https://developer.android.com/reference/java/lang/Object) ||
| ↳ | android.net.eap.EapSessionConfig.EapMethodConfig |

Known direct subclasses [EapSessionConfig.EapAkaConfig](https://developer.android.com/reference/android/net/eap/EapSessionConfig.EapAkaConfig), [EapSessionConfig.EapMsChapV2Config](https://developer.android.com/reference/android/net/eap/EapSessionConfig.EapMsChapV2Config), [EapSessionConfig.EapSimConfig](https://developer.android.com/reference/android/net/eap/EapSessionConfig.EapSimConfig), [EapSessionConfig.EapTtlsConfig](https://developer.android.com/reference/android/net/eap/EapSessionConfig.EapTtlsConfig) [EapSessionConfig.EapAkaConfig](https://developer.android.com/reference/android/net/eap/EapSessionConfig.EapAkaConfig) EapAkaConfig represents the configs needed for an EAP AKA session. [EapSessionConfig.EapMsChapV2Config](https://developer.android.com/reference/android/net/eap/EapSessionConfig.EapMsChapV2Config) EapMsChapV2Config represents the configs needed for an EAP MSCHAPv2 session. [EapSessionConfig.EapSimConfig](https://developer.android.com/reference/android/net/eap/EapSessionConfig.EapSimConfig) EapSimConfig represents the configs needed for an EAP SIM session. [EapSessionConfig.EapTtlsConfig](https://developer.android.com/reference/android/net/eap/EapSessionConfig.EapTtlsConfig) EapTtlsConfig represents the configs needed for an EAP-TTLS session. Known indirect subclasses [EapSessionConfig.EapAkaPrimeConfig](https://developer.android.com/reference/android/net/eap/EapSessionConfig.EapAkaPrimeConfig) [EapSessionConfig.EapAkaPrimeConfig](https://developer.android.com/reference/android/net/eap/EapSessionConfig.EapAkaPrimeConfig) EapAkaPrimeConfig represents the configs needed for an EAP-AKA' session.   

*** ** * ** ***

EapMethodConfig represents a generic EAP method configuration.

## Summary

| ### Constants ||
|---|---|
| `int` | `https://developer.android.com/reference/android/net/eap/EapSessionConfig.EapMethodConfig#EAP_TYPE_AKA` EAP-Type value for the EAP-AKA method. |
| `int` | `https://developer.android.com/reference/android/net/eap/EapSessionConfig.EapMethodConfig#EAP_TYPE_AKA_PRIME` EAP-Type value for the EAP-AKA' method. |
| `int` | `https://developer.android.com/reference/android/net/eap/EapSessionConfig.EapMethodConfig#EAP_TYPE_MSCHAP_V2` EAP-Type value for the EAP-MS-CHAPv2 method. |
| `int` | `https://developer.android.com/reference/android/net/eap/EapSessionConfig.EapMethodConfig#EAP_TYPE_SIM` EAP-Type value for the EAP-SIM method. |
| `int` | `https://developer.android.com/reference/android/net/eap/EapSessionConfig.EapMethodConfig#EAP_TYPE_TTLS` EAP-Type value for the EAP-TTLS method. |

| ### Public methods ||
|---|---|
| ` boolean` | ` https://developer.android.com/reference/android/net/eap/EapSessionConfig.EapMethodConfig#equals(java.lang.Object)(https://developer.android.com/reference/java/lang/Object o) ` Indicates whether some other object is "equal to" this one. |
| ` int` | ` https://developer.android.com/reference/android/net/eap/EapSessionConfig.EapMethodConfig#getMethodType()() ` Retrieves the EAP method type |
| ` int` | ` https://developer.android.com/reference/android/net/eap/EapSessionConfig.EapMethodConfig#hashCode()() ` Returns a hash code value for the object. |

### Inherited methods

From class ` https://developer.android.com/reference/java/lang/Object ` ` https://developer.android.com/reference/java/lang/Object` ` https://developer.android.com/reference/java/lang/Object#clone()() `

Creates and returns a copy of this object.
` boolean` ` https://developer.android.com/reference/java/lang/Object#equals(java.lang.Object)(https://developer.android.com/reference/java/lang/Object obj) `

Indicates whether some other object is "equal to" this one.
` void` ` https://developer.android.com/reference/java/lang/Object#finalize()() `

Called by the garbage collector on an object when garbage collection determines that there are no more references to the object.
` final https://developer.android.com/reference/java/lang/Class<?>` ` https://developer.android.com/reference/java/lang/Object#getClass()() `

Returns the runtime class of this `Object`.
` int` ` https://developer.android.com/reference/java/lang/Object#hashCode()() `

Returns a hash code value for the object.
` final void` ` https://developer.android.com/reference/java/lang/Object#notify()() `

Wakes up a single thread that is waiting on this object's monitor.
` final void` ` https://developer.android.com/reference/java/lang/Object#notifyAll()() `

Wakes up all threads that are waiting on this object's monitor.
` https://developer.android.com/reference/java/lang/String` ` https://developer.android.com/reference/java/lang/Object#toString()() `

Returns a string representation of the object.
` final void` ` https://developer.android.com/reference/java/lang/Object#wait(long,%20int)(long timeoutMillis, int nanos) `

Causes the current thread to wait until it is awakened, typically by being *notified* or *interrupted*, or until a certain amount of real time has elapsed.
` final void` ` https://developer.android.com/reference/java/lang/Object#wait(long)(long timeoutMillis) `

Causes the current thread to wait until it is awakened, typically by being *notified* or *interrupted*, or until a certain amount of real time has elapsed.
` final void` ` https://developer.android.com/reference/java/lang/Object#wait()() `

Causes the current thread to wait until it is awakened, typically by being *notified* or *interrupted*.

## Constants

### EAP_TYPE_AKA

Added in [API level 31](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EAP_TYPE_AKA
```

EAP-Type value for the EAP-AKA method.

To include EAP-AKA as an authentication method, see `https://developer.android.com/reference/android/net/eap/EapSessionConfig.Builder#setEapAkaConfig(int,%20int)`.

<br />

**See also:**

- [RFC 4187, Extensible Authentication Protocol Method for 3rd Generation Authentication and Key Agreement (EAP-AKA)](https://tools.ietf.org/html/rfc4187)

Constant Value: 23 (0x00000017)

### EAP_TYPE_AKA_PRIME

Added in [API level 31](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EAP_TYPE_AKA_PRIME
```

EAP-Type value for the EAP-AKA' method.

To include EAP-AKA' as an authentication method, see `https://developer.android.com/reference/android/net/eap/EapSessionConfig.Builder#setEapAkaPrimeConfig(int,%20int,%20java.lang.String,%20boolean)`.

<br />

**See also:**

- [RFC 5448, Improved Extensible Authentication Protocol Method for 3rd Generation Authentication and Key Agreement (EAP-AKA')](https://tools.ietf.org/html/rfc5448)

Constant Value: 50 (0x00000032)

### EAP_TYPE_MSCHAP_V2

Added in [API level 31](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EAP_TYPE_MSCHAP_V2
```

EAP-Type value for the EAP-MS-CHAPv2 method.

To include EAP-MS-CHAPv2 as an authentication method, see `https://developer.android.com/reference/android/net/eap/EapSessionConfig.Builder#setEapMsChapV2Config(java.lang.String,%20java.lang.String)`.

<br />

**See also:**

- [Microsoft EAP CHAP Extensions Draft (EAP MSCHAPv2)](https://tools.ietf.org/html/draft-kamath-pppext-eap-mschapv2-02)

Constant Value: 26 (0x0000001a)

### EAP_TYPE_SIM

Added in [API level 31](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EAP_TYPE_SIM
```

EAP-Type value for the EAP-SIM method.

To include EAP-SIM as an authentication method, see `https://developer.android.com/reference/android/net/eap/EapSessionConfig.Builder#setEapSimConfig(int,%20int)`.

<br />

**See also:**

- [RFC 4186, Extensible Authentication Protocol Method for Global System for Mobile Communications (GSM) Subscriber Identity Modules (EAP-SIM)](https://tools.ietf.org/html/rfc4186)

Constant Value: 18 (0x00000012)

### EAP_TYPE_TTLS

Added in [API level 31](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public static final int EAP_TYPE_TTLS
```

EAP-Type value for the EAP-TTLS method.

To include EAP-TTLS as an authentication method, see `https://developer.android.com/reference/android/net/eap/EapSessionConfig.Builder#setEapTtlsConfig(java.security.cert.X509Certificate,%20android.net.eap.EapSessionConfig)`.

<br />

**See also:**

- [RFC 5281, Extensible Authentication Protocol Tunneled Transport Layer Security Authenticated Protocol Version 0 (EAP-TTLSv0)](https://tools.ietf.org/html/rfc5281)

Constant Value: 21 (0x00000015)

## Public methods

### equals

Added in [API level 31](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public boolean equals (Object o)
```

Indicates whether some other object is "equal to" this one.

The `equals` method implements an equivalence relation on non-null object references:

- It is *reflexive*: for any non-null reference value `x`, `x.equals(x)` should return `true`.
- It is *symmetric*: for any non-null reference values `x` and `y`, `x.equals(y)` should return `true` if and only if `y.equals(x)` returns `true`.
- It is *transitive*: for any non-null reference values `x`, `y`, and `z`, if `x.equals(y)` returns `true` and `y.equals(z)` returns `true`, then `x.equals(z)` should return `true`.
- It is *consistent*: for any non-null reference values `x` and `y`, multiple invocations of `x.equals(y)` consistently return `true` or consistently return `false`, provided no information used in `equals` comparisons on the objects is modified.
- For any non-null reference value `x`, `x.equals(null)` should return `false`.

An equivalence relation partitions the elements it operates on into *equivalence classes*; all the members of an equivalence class are equal to each other. Members of an equivalence class are substitutable for each other, at least for some purposes.

<br />

| Parameters ||
|---|---|
| `o` | `Object`: the reference object with which to compare. <br /> |

| Returns ||
|---|---|
| `boolean` | `true` if this object is the same as the obj argument; `false` otherwise. <br /> |

### getMethodType

Added in [API level 31](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public int getMethodType ()
```

Retrieves the EAP method type

<br />

| Returns ||
|---|---|
| `int` | the IANA-defined EAP method constant <br /> |

### hashCode

Added in [API level 31](https://developer.android.com/guide/topics/manifest/uses-sdk-element#ApiLevels)

```
public int hashCode ()
```

Returns a hash code value for the object. This method is supported for the benefit of hash tables such as those provided by `https://developer.android.com/reference/java/util/HashMap`.

The general contract of `hashCode` is:

- Whenever it is invoked on the same object more than once during an execution of a Java application, the `hashCode` method must consistently return the same integer, provided no information used in `equals` comparisons on the object is modified. This integer need not remain consistent from one execution of an application to another execution of the same application.
- If two objects are equal according to the `https://developer.android.com/reference/java/lang/Object#equals(java.lang.Object)` method, then calling the `hashCode` method on each of the two objects must produce the same integer result.
- It is *not* required that if two objects are unequal according to the `https://developer.android.com/reference/java/lang/Object#equals(java.lang.Object)` method, then calling the `hashCode` method on each of the two objects must produce distinct integer results. However, the programmer should be aware that producing distinct integer results for unequal objects may improve the performance of hash tables.

<br />

<br />

| Returns ||
|---|---|
| `int` | a hash code value for this object. <br /> |